summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-ecdsa_0.17.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-ecdsa_0.17.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-ecdsa_0.17.0.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-ecdsa_0.17.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-ecdsa_0.17.0.bb
new file mode 100644
index 000000000..1401f8e58
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-ecdsa_0.17.0.bb
@@ -0,0 +1,13 @@
+SUMMARY = "ECDSA cryptographic signature library (pure python)"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=66ffc5e30f76cbb5358fe54b645e5a1d"
+
+DEPENDS += "python3-pip python3-pbr"
+
+PYPI_PACKAGE = "ecdsa"
+SRC_URI[sha256sum] = "b9f500bb439e4153d0330610f5d26baaf18d17b8ced1bc54410d189385ea68aa"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "python3-six python3-gmpy2 python3-pbr"