summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-flask-migrate_2.5.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-flask-migrate_2.5.3.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-flask-migrate_2.5.3.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-flask-migrate_2.5.3.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-flask-migrate_2.5.3.bb
new file mode 100644
index 000000000..54fa1dd97
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-flask-migrate_2.5.3.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "SQLAlchemy database migrations for Flask applications using Alembic"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b69377f79f3f48c661701236d5a6a85"
+
+SRC_URI[md5sum] = "707d4a5fd4e11d3113a1228aa7793176"
+SRC_URI[sha256sum] = "a69d508c2e09d289f6e55a417b3b8c7bfe70e640f53d2d9deb0d056a384f37ee"
+
+PYPI_PACKAGE = "Flask-Migrate"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-flask-sqlalchemy \
+ ${PYTHON_PN}-alembic \
+ ${PYTHON_PN}-flask \
+ "