summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-gmqtt_0.4.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-gmqtt_0.4.4.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-gmqtt_0.4.4.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-gmqtt_0.4.4.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-gmqtt_0.4.4.bb
new file mode 100644
index 000000000..ff89087a1
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-gmqtt_0.4.4.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Client for MQTT protocol"
+HOMEPAGE = "https://github.com/wialon/gmqtt"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=903f1792621a3b35ee546da75d139177"
+
+SRC_URI[md5sum] = "af3a2c6c2f8e3c934b31159ffdce5fd6"
+SRC_URI[sha256sum] = "b96bca8a54b8af057d4cc42a79f9e2b40cdbb5a2bfebbc5f05ee35575d3e3089"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ python3-asyncio \
+ python3-core \
+ python3-datetime \
+ python3-json \
+ python3-logging \
+ python3-netclient \
+ python3-typing \
+"
+
+BBCLASSEXTEND = "native nativesdk"