summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch b/meta-openembedded/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch
index 4881b023c..9b79cc539 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch
@@ -1,4 +1,4 @@
-From e6c0d487fb5e6063305b8b3187896fbfe5720ed2 Mon Sep 17 00:00:00 2001
+From b1d4d171fd13624f3d8bb917f716b62494066501 Mon Sep 17 00:00:00 2001
From: Leon Anavi <leon.anavi@konsulko.com>
Date: Mon, 22 Feb 2021 18:42:43 +0200
Subject: [PATCH] setup.py: Fix numpy version
@@ -14,12 +14,12 @@ Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
-index 7dbe583..6602c97 100755
+index 4b2890c..42ba21b 100755
--- a/setup.py
+++ b/setup.py
@@ -49,7 +49,7 @@ SETUP_REQUIRES = [
- f"Cython >=0.29; python_version<'3.8'",
- f"Cython >=0.29.14; python_version>='3.8'",
+ "Cython >=0.29.14; python_version=='3.8'",
+ "Cython >=0.29.15; python_version>='3.9'",
] + [
- f"numpy =={np_min}; python_version{py_condition}"
+ f"numpy >={np_min}; python_version{py_condition}"