summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-html5lib_1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-html5lib_1.1.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-html5lib_1.1.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-html5lib_1.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-html5lib_1.1.bb
new file mode 100644
index 000000000..59f3cc945
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-html5lib_1.1.bb
@@ -0,0 +1,17 @@
+SUMMARY = "HTML parser based on the WHATWG HTML specifcation"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1ba5ada9e6fead1fdc32f43c9f10ba7c"
+
+SRC_URI[md5sum] = "6748742e2ec4cb99287a6bc82bcfe2b0"
+SRC_URI[sha256sum] = "b2e5b40261e20f354d198eae92afc10d750afb487ed5e50f9c4eaf07c184146f"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-lxml \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-webencodings \
+ ${PYTHON_PN}-xml \
+"
+
+BBCLASSEXTEND = "native nativesdk"