summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-humanize_3.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-humanize_3.0.1.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-humanize_3.0.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-humanize_3.0.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-humanize_3.0.1.bb
new file mode 100644
index 000000000..92831bf13
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-humanize_3.0.1.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Python humanize utilities"
+HOMEPAGE = "http://github.com/jmoiron/humanize"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=4ecc42519e84f6f3e23529464df7bd1d"
+
+SRC_URI[md5sum] = "53faa88dedddba1227f9c41d65440c54"
+SRC_URI[sha256sum] = "8ff8f292c9bf52bbefdc620410e7defd1c95e7eeb1a5cfc2859aaea4b1877ff5"
+
+inherit pypi setuptools3
+
+DEPENDS += "\
+ ${PYTHON_PN}-setuptools-scm-native \
+"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+"
+
+BBCLASSEXTEND = "native nativesdk"