summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-hyperlink_19.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-hyperlink_19.0.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-hyperlink_19.0.0.bb19
1 files changed, 17 insertions, 2 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-hyperlink_19.0.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-hyperlink_19.0.0.bb
index 70813bf34..3ee098ad6 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-hyperlink_19.0.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-hyperlink_19.0.0.bb
@@ -1,2 +1,17 @@
-inherit setuptools3
-require python-hyperlink.inc
+DESCRIPTION = "A featureful, correct URL for Python"
+HOMEPAGE = "https://github.com/python-hyper/hyperlink"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3893d4ed05dcc823f8ed685a9ea19bcb"
+
+SRC_URI[sha256sum] = "4288e34705da077fada1111a24a0aa08bb1e76699c9ce49876af722441845654"
+SRC_URI[md5sum] = "4772fb4d87c26a1ab22a6161424e3cba"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-stringold ${PYTHON_PN}-netclient ${PYTHON_PN}-idna"
+
+PACKAGES =. "${PN}-test "
+
+FILES_${PN}-test += " \
+ ${PYTHON_SITEPACKAGES_DIR}/hyperlinkt/test \
+"