summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch b/meta-openembedded/meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch
new file mode 100644
index 000000000..1b6e89043
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch
@@ -0,0 +1,30 @@
+Fixed host contamination of include files
+
+python3-icu-2.5-r0 do_package_qa: QA Issue: python3-icu: The compile log indicates that host include and/or library paths were used.
+
+Also, don't use icu-config
+
+Upstream-Status: [inappropriate] OE specific
+Signed-off-by: Armin Kuster <akuster808@gmail.com>
+
+Index: PyICU-2.5/setup.py
+===================================================================
+--- PyICU-2.5.orig/setup.py
++++ PyICU-2.5/setup.py
+@@ -81,7 +81,7 @@ Building PyICU %s for ICU %s (max ICU ma
+
+ CONFIGURE_WITH_ICU_CONFIG = {
+ 'darwin': True,
+- 'linux': True,
++ 'linux': False,
+ 'freebsd': False, # not tested
+ 'win32': False, # no icu-config
+ 'sunos5': False, # not tested
+@@ -274,7 +274,6 @@ setup(name="PyICU",
+ ext_modules=[Extension('_icu',
+ [filename for filename in sorted(os.listdir(os.curdir))
+ if filename.endswith('.cpp')],
+- include_dirs=_includes,
+ extra_compile_args=_cflags,
+ extra_link_args=_lflags,
+ libraries=_libraries)],