summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-icu
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-icu')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-icu/0001-Fix-host-contamination-of-include-files.patch (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch)26
1 files changed, 18 insertions, 8 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch b/meta-openembedded/meta-python/recipes-devtools/python/python3-icu/0001-Fix-host-contamination-of-include-files.patch
index 1b6e89043..c45217a88 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-icu/0001-Fix-host-contamination-of-include-files.patch
@@ -1,17 +1,24 @@
-Fixed host contamination of include files
+From 8abf79f77d9151d6786da3c8e868117822bce6d4 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Fri, 16 Apr 2021 10:48:36 -0700
+Subject: [PATCH] Fix host contamination of include files
python3-icu-2.5-r0 do_package_qa: QA Issue: python3-icu: The compile log indicates that host include and/or library paths were used.
Also, don't use icu-config
-Upstream-Status: [inappropriate] OE specific
+Upstream-Status: Inappropriate [OE specific]
Signed-off-by: Armin Kuster <akuster808@gmail.com>
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ setup.py | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
-Index: PyICU-2.5/setup.py
-===================================================================
---- PyICU-2.5.orig/setup.py
-+++ PyICU-2.5/setup.py
-@@ -81,7 +81,7 @@ Building PyICU %s for ICU %s (max ICU ma
+diff --git a/setup.py b/setup.py
+index e647db4..abed399 100644
+--- a/setup.py
++++ b/setup.py
+@@ -81,7 +81,7 @@ Building PyICU %s for ICU %s (max ICU major version supported: %s)
CONFIGURE_WITH_ICU_CONFIG = {
'darwin': True,
@@ -20,7 +27,7 @@ Index: PyICU-2.5/setup.py
'freebsd': False, # not tested
'win32': False, # no icu-config
'sunos5': False, # not tested
-@@ -274,7 +274,6 @@ setup(name="PyICU",
+@@ -267,7 +267,6 @@ setup(name="PyICU",
ext_modules=[Extension('_icu',
[filename for filename in sorted(os.listdir(os.curdir))
if filename.endswith('.cpp')],
@@ -28,3 +35,6 @@ Index: PyICU-2.5/setup.py
extra_compile_args=_cflags,
extra_link_args=_lflags,
libraries=_libraries)],
+--
+2.31.1
+