summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-isort_4.3.21.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-isort_4.3.21.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-isort_4.3.21.bb19
1 files changed, 17 insertions, 2 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-isort_4.3.21.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-isort_4.3.21.bb
index 755b3e2f2..e0b21ab55 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-isort_4.3.21.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-isort_4.3.21.bb
@@ -1,2 +1,17 @@
-inherit setuptools3
-require python-isort.inc
+SUMMARY = "A Python utility / library to sort Python imports."
+HOMEPAGE = "https://pypi.python.org/pypi/isort"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
+
+SRC_URI[md5sum] = "05d66f2eb7ce2c2d702e86bac24bf9e4"
+SRC_URI[sha256sum] = "54da7e92468955c4fceacd0c86bd0ec997b0e1ee80d97f67c35a78b719dccab1"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-shell \
+"
+
+BBCLASSEXTEND = "native nativesdk"