summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-itsdangerous_1.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-itsdangerous_1.1.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-itsdangerous_1.1.0.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-itsdangerous_1.1.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-itsdangerous_1.1.0.bb
index a71c20f0e..7f50641c8 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-itsdangerous_1.1.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-itsdangerous_1.1.0.bb
@@ -1,6 +1,17 @@
+SUMMARY = "Various helpers to pass trusted data to untrusted environments and back."
+HOMEPAGE = "http://github.com/mitsuhiko/itsdangerous"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=370799bf709a1e4a6a369fa089ac73a6"
+
+SRC_URI[md5sum] = "9b7f5afa7f1e3acfb7786eeca3d99307"
+SRC_URI[sha256sum] = "321b033d07f2a4136d3ec762eac9f16a10ccd60f53c0c91af90217ace7ba1f19"
+
inherit pypi setuptools3
-require python-itsdangerous.inc
+
+CLEANBROKEN = "1"
RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-simplejson \
+ ${PYTHON_PN}-netclient \
${PYTHON_PN}-compression \
"