summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-luma-oled_3.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-luma-oled_3.5.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-luma-oled_3.5.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-luma-oled_3.5.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-luma-oled_3.5.0.bb
new file mode 100644
index 000000000..39bc37fda
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-luma-oled_3.5.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "A small library to drive an OLED device"
+DESCRIPTION = "\
+A small library to drive an OLED device with either SSD1306 , SSD1309, SSD1322, \
+SSD1325, SSD1327, SSD1331, SSD1351 or SH1106 chipset"
+HOMEPAGE = "https://github.com/rm-hull/luma.oled"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=c328c862c3335ad464e1c9a3ba574249"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "64436aaa7a05a205430b38d2f9a9bec7"
+SRC_URI[sha256sum] = "ca62fd7337ee9780b32a8cdc10bcd69879f2cfd97720ab2e17e254a160f6c24f"
+
+CLEANBROKEN = "1"
+
+PYPI_PACKAGE = "luma.oled"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-luma-core \
+"