summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-matplotlib_3.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-matplotlib_3.2.2.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-matplotlib_3.2.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-matplotlib_3.2.2.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-matplotlib_3.2.2.bb
new file mode 100644
index 000000000..b32177d9b
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-matplotlib_3.2.2.bb
@@ -0,0 +1,37 @@
+SUMMARY = "matplotlib: plotting with Python"
+DESCRIPTION = "\
+Matplotlib is a Python 2D plotting library which produces \
+publication-quality figures in a variety of hardcopy formats \
+and interactive environments across platforms."
+HOMEPAGE = "https://github.com/matplotlib/matplotlib"
+SECTION = "devel/python"
+LICENSE = "PSF"
+LIC_FILES_CHKSUM = "\
+ file://setup.py;beginline=253;endline=253;md5=2a114620e4e6843aa7568d5902501753 \
+ file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74 \
+"
+DEPENDS = "\
+ freetype \
+ libpng \
+ python3-numpy-native \
+ python3-dateutil-native \
+ python3-pytz-native \
+"
+
+SRC_URI[md5sum] = "b60cd68f792a30173d825e16482aedd8"
+SRC_URI[sha256sum] = "3d77a6630d093d74cbbfebaa0571d00790966be1ed204e4a8239f5cbd6835c5d"
+
+inherit pypi setuptools3 pkgconfig
+
+RDEPENDS_${PN} = "\
+ freetype \
+ libpng \
+ python3-numpy \
+ python3-pyparsing \
+ python3-cycler \
+ python3-dateutil \
+ python3-kiwisolver \
+ python3-pytz \
+"
+
+BBCLASSEXTEND = "native"