summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-mock_4.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-mock_4.0.2.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-mock_4.0.2.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-mock_4.0.2.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-mock_4.0.2.bb
new file mode 100644
index 000000000..39ab6d01f
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-mock_4.0.2.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "A Python Mocking and Patching Library for Testing"
+HOMEPAGE = "https://pypi.python.org/pypi/mock"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=de9dfbf780446b18aab11f00baaf5b7e"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-prettytable \
+ ${PYTHON_PN}-cmd2 \
+ ${PYTHON_PN}-pyparsing \
+ ${PYTHON_PN}-mccabe \
+ ${PYTHON_PN}-pep8 \
+ ${PYTHON_PN}-pyflakes"
+
+SRC_URI[md5sum] = "6466619b89c2969dc57722ad73f85676"
+SRC_URI[sha256sum] = "dd33eb70232b6118298d516bbcecd26704689c386594f0f3c4f13867b2c56f72"