summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-mock_4.0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-mock_4.0.3.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-mock_4.0.3.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-mock_4.0.3.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-mock_4.0.3.bb
new file mode 100644
index 000000000..b34f25b93
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-mock_4.0.3.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "A Python Mocking and Patching Library for Testing"
+HOMEPAGE = "https://pypi.python.org/pypi/mock"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=de9dfbf780446b18aab11f00baaf5b7e"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-prettytable \
+ ${PYTHON_PN}-cmd2 \
+ ${PYTHON_PN}-pyparsing \
+ ${PYTHON_PN}-mccabe \
+ ${PYTHON_PN}-pep8 \
+ ${PYTHON_PN}-pyflakes"
+
+SRC_URI[sha256sum] = "7d3fbbde18228f4ff2f1f119a45cdffa458b4c0dee32eb4d2bb2f82554bac7bc"