summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-multidict_5.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-multidict_5.0.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-multidict_5.0.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-multidict_5.0.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-multidict_5.0.0.bb
new file mode 100644
index 000000000..676fbae7e
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-multidict_5.0.0.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Multidicts are useful for working with HTTP headers, URL query args etc."
+HOMEPAGE = "https://github.com/aio-libs/multidict/"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e74c98abe0de8f798ca609137f9cef4a"
+
+SRC_URI[md5sum] = "c2c3311e25636a6f213e998cd1e80d72"
+SRC_URI[sha256sum] = "1b324444299c3a49b601b1bf621fc21704e29066f6ac2b7d7e4034a4a18662a1"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+BBCLASSEXTEND = "native nativesdk"