summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-mypy_0.800.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-mypy_0.800.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-mypy_0.800.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-mypy_0.800.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-mypy_0.800.bb
new file mode 100644
index 000000000..0d019dfe1
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-mypy_0.800.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Optional static typing for Python 3 and 2 (PEP 484)"
+HOMEPAGE = "https://github.com/python/mypy"
+LICENSE = "MIT & Python-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6afb7c151c4dedb5c3dc292cc120fadc"
+
+RDEPENDS_${PN} = " \
+ ${PYTHON_PN}-mypy-extensions \
+ ${PYTHON_PN}-typed-ast \
+ ${PYTHON_PN}-typing-extensions \
+"
+
+PYPI_PACKAGE = "mypy"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "e0202e37756ed09daf4b0ba64ad2c245d357659e014c3f51d8cd0681ba66940a"
+
+BBCLASSEXTEND = "native"