summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-pandas_1.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-pandas_1.3.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pandas_1.3.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pandas_1.3.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pandas_1.3.0.bb
new file mode 100644
index 000000000..b98e2865c
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pandas_1.3.0.bb
@@ -0,0 +1,26 @@
+SUMMARY = "pandas library for high-performance data analysis tools"
+DESCRIPTION = "pandas is an open source, BSD-licensed library providing \
+high-performance, easy-to-use data structures and data analysis tools for \
+the Python programming language."
+HOMEPAGE = "http://pandas.pydata.org/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3f23c5c092b74d245d48eeef72bc3fd2"
+
+SRC_URI[sha256sum] = "c554e6c9cf2d5ea1aba5979cc837b3649539ced0e18ece186f055450c86622e2"
+
+inherit pypi setuptools3
+
+DEPENDS += " \
+ ${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \
+"
+
+CFLAGS_append_toolchain-clang = " -Wno-error=deprecated-declarations"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-numpy \
+ ${PYTHON_PN}-dateutil \
+ ${PYTHON_PN}-dateutil-zoneinfo \
+ ${PYTHON_PN}-pytz \
+ ${PYTHON_PN}-profile \
+"