summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-periphery_2.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-periphery_2.1.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-periphery_2.1.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-periphery_2.1.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-periphery_2.1.0.bb
new file mode 100644
index 000000000..3cd9004df
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-periphery_2.1.0.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "A pure Python 2/3 library for peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO, Serial) in Linux."
+HOMEPAGE = "http://pythonhosted.org/python-periphery/"
+LICENSE = "MIT"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fea92e2e010ccb151792c29fadc2db7b"
+
+SRC_URI[md5sum] = "27cdd7e026438067a238fb04ed5766a3"
+SRC_URI[sha256sum] = "57baa82e6bc59b67747317d16ad0cf9626826e8d43233af13bce924660500bd6"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "python-periphery"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-mmap"