summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.7.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.7.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.7.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.7.0.bb
new file mode 100644
index 000000000..348af6ec9
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pybind11_2.7.0.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Seamless operability between C++11 and Python"
+HOMEPAGE = "https://github.com/wjakob/pybind11"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=774f65abd8a7fe3124be2cdf766cd06f"
+
+DEPENDS = "boost"
+
+SRC_URI = "git://github.com/pybind/pybind11.git \
+ file://0001-Do-not-strip-binaries.patch \
+ file://0001-Do-not-check-pointer-size-when-cross-compiling.patch \
+"
+SRCREV = "65e95ea8675ea34bdd566d6461330f25c651e5a8"
+
+S = "${WORKDIR}/git"
+
+BBCLASSEXTEND = "native"
+
+EXTRA_OECMAKE = "-DPYBIND11_TEST=OFF"
+
+inherit cmake setuptools3 python3native
+
+do_configure() {
+ cmake_do_configure
+}
+
+do_compile() {
+ distutils3_do_compile
+ cmake_do_compile
+}
+
+do_install() {
+ distutils3_do_install
+ cmake_do_install
+}
+
+BBCLASSEXTEND = "native nativesdk"