summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-pyelftools_0.25.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-pyelftools_0.25.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pyelftools_0.25.bb16
1 files changed, 14 insertions, 2 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pyelftools_0.25.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyelftools_0.25.bb
index 56eb8c4cd..03d96db3c 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pyelftools_0.25.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyelftools_0.25.bb
@@ -1,2 +1,14 @@
-inherit setuptools3
-require python-pyelftools.inc
+DESCRIPTION = "pyelftools is a pure-Python library for parsing and analyzing ELF files and DWARF debugging information"
+HOMEPAGE = "https://github.com/eliben/pyelftools"
+SECTION = "devel/python"
+LICENSE = "PD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5ce2a2b07fca326bc7c146d10105ccfc"
+
+SRC_URI[md5sum] = "c5629b9a5d19c82107a946cce52eeec2"
+SRC_URI[sha256sum] = "89c6da6f56280c37a5ff33468591ba9a124e17d71fe42de971818cbff46c1b24"
+
+PYPI_PACKAGE = "pyelftools"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native"