summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-pyfirmata_1.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-pyfirmata_1.1.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pyfirmata_1.1.0.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pyfirmata_1.1.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyfirmata_1.1.0.bb
index 25af1b5c0..c6e95eb52 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pyfirmata_1.1.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyfirmata_1.1.0.bb
@@ -1,3 +1,13 @@
-inherit setuptools3
-require python-pyfirmata.inc
+SUMMARY = "A Python interface for the Firmata protocol"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=84ddcef430b7c44caa22b2ff4b37a3df"
+PYPI_PACKAGE = "pyFirmata"
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-pyserial \
+"
+
+SRC_URI[md5sum] = "159673cfb56c72ceafc30fe91eedd847"
+SRC_URI[sha256sum] = "cc180d1b30c85a2bbca62c15fef1b871db048cdcfa80959968356d97bd3ff08e"
+
+inherit pypi setuptools3