summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-pyjwt_1.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-pyjwt_1.7.1.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pyjwt_1.7.1.bb18
1 files changed, 16 insertions, 2 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pyjwt_1.7.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyjwt_1.7.1.bb
index dc16d2282..d2f7be46c 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pyjwt_1.7.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyjwt_1.7.1.bb
@@ -1,2 +1,16 @@
-require python-pyjwt.inc
-inherit setuptools3
+SUMMARY = "JSON Web Token implementation in Python"
+DESCRIPTION = "A Python implementation of JSON Web Token draft 32.\
+ Original implementation was written by https://github.com/progrium"
+HOMEPAGE = "http://github.com/jpadilla/pyjwt"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=68626705a7b513ca8d5f44a3e200ed0c"
+
+SRC_URI[md5sum] = "a4712f980c008696e13e09504120b2a0"
+SRC_URI[sha256sum] = "8d59a976fb773f3e6a39c85636357c4f0e242707394cadadd9814f5cbaa20e96"
+
+PYPI_PACKAGE = "PyJWT"
+inherit pypi setuptools3
+
+RDEPENDS_${PN} = "${PYTHON_PN}-cryptography"
+
+BBCLASSEXTEND = "native nativesdk"