summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-pyperclip_1.8.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-pyperclip_1.8.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pyperclip_1.8.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pyperclip_1.8.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyperclip_1.8.0.bb
new file mode 100644
index 000000000..8f331529a
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyperclip_1.8.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "A cross-platform clipboard module for Python. (only handles plain text for now)"
+HOMEPAGE = "https://github.com/asweigart/pyperclip"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=d7dd4b0d1f7153322a546e89b5a0a632"
+
+SRC_URI[md5sum] = "c2564a74b909b6fc32401afd619de83d"
+SRC_URI[sha256sum] = "b75b975160428d84608c26edba2dec146e7799566aea42c1fe1b32e72b6028f2"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-ctypes \
+"
+
+BBCLASSEXTEND = "native nativesdk"