summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-pyrsistent_0.15.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-pyrsistent_0.15.7.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pyrsistent_0.15.7.bb16
1 files changed, 15 insertions, 1 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pyrsistent_0.15.7.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyrsistent_0.15.7.bb
index 2e567e9f9..53251aa55 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pyrsistent_0.15.7.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyrsistent_0.15.7.bb
@@ -1,2 +1,16 @@
+SUMMARY = "Persistent/Immutable/Functional data structures for Python"
+HOMEPAGE = "https://github.com/tobgu/pyrsistent"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENCE.mit;md5=ca574f2891cf528b3e7a2ee570337e7c"
+
+SRC_URI[md5sum] = "da9486d00ef5b213f40d5cf3c5bca82d"
+SRC_URI[sha256sum] = "cdc7b5e3ed77bed61270a47d35434a30617b9becdf2478af76ad2c6ade307280"
+
inherit pypi setuptools3
-require python-pyrsistent.inc
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-six \
+"
+
+BBCLASSEXTEND = "native nativesdk"