summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-pytest-runner_5.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-pytest-runner_5.2.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pytest-runner_5.2.bb18
1 files changed, 16 insertions, 2 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pytest-runner_5.2.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pytest-runner_5.2.bb
index df56ba6d4..d00cd4873 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pytest-runner_5.2.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pytest-runner_5.2.bb
@@ -1,2 +1,16 @@
-inherit setuptools3
-require python-pytest-runner.inc
+SUMMARY = "Invoke py.test as distutils command with dependency resolution"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a33f38bbf47d48c70fe0d40e5f77498e"
+
+SRC_URI[md5sum] = "e5f66b8e8e87f62c59631c35c919d321"
+SRC_URI[sha256sum] = "96c7e73ead7b93e388c5d614770d2bae6526efd997757d3543fe17b557a0942b"
+
+inherit pypi setuptools3
+
+DEPENDS += " \
+ ${PYTHON_PN}-setuptools-scm-native"
+
+RDEPENDS_${PN} = "${PYTHON_PN}-py ${PYTHON_PN}-setuptools ${PYTHON_PN}-debugger ${PYTHON_PN}-json \
+ ${PYTHON_PN}-io"
+
+BBCLASSEXTEND = "native nativesdk"