summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-pytz_2019.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-pytz_2019.3.bb')
-rw-r--r--[-rwxr-xr-x]meta-openembedded/meta-python/recipes-devtools/python/python3-pytz_2019.3.bb38
1 files changed, 36 insertions, 2 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pytz_2019.3.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pytz_2019.3.bb
index 19a89dc55..c28a0148b 100755..100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pytz_2019.3.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pytz_2019.3.bb
@@ -1,2 +1,36 @@
-inherit setuptools3
-require python-pytz.inc
+SUMMARY = "World timezone definitions, modern and historical"
+HOMEPAGE = "http://pythonhosted.org/pytz"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4878a915709225bceab739bdc2a18e8d"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI[md5sum] = "c3d84a465fc56a4edd52cca8873ac0df"
+SRC_URI[sha256sum] = "b02c06db6cf09c12dd25137e563b31700d3b80fcc4ad23abb7a315f2789819be"
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-doctest \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-threading \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/pytz
+ install -d ${D}${PTEST_PATH}/pytz/tests
+ cp -rf ${S}/pytz/tests/* ${D}${PTEST_PATH}/pytz/tests/
+ cp -f ${S}/README.txt ${D}${PTEST_PATH}/
+
+}