summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-pyusb_1.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-pyusb_1.2.1.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pyusb_1.2.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pyusb_1.2.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyusb_1.2.1.bb
new file mode 100644
index 000000000..30b2c6d88
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyusb_1.2.1.bb
@@ -0,0 +1,18 @@
+SUMMARY = "PyUSB provides USB access on the Python language"
+HOMEPAGE = "http://pyusb.sourceforge.net/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e64a29fcd3c3dd356a24e235dfcb3905"
+
+DEPENDS += "libusb1 ${PYTHON_PN}-setuptools-scm-native"
+
+RDEPENDS_${PN} += " \
+ python3-logging \
+"
+
+SRC_URI[sha256sum] = "a4cc7404a203144754164b8b40994e2849fde1cfff06b08492f12fff9d9de7b9"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "libusb1"
+
+BBCLASSEXTEND = "native nativesdk"