summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-sh_1.14.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-sh_1.14.1.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-sh_1.14.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-sh_1.14.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-sh_1.14.1.bb
new file mode 100644
index 000000000..c7b50c21a
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-sh_1.14.1.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Python subprocess replacement"
+HOMEPAGE = "https://github.com/amoffat/sh"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5317094292296f03405f59ae5f6544b6"
+
+SRC_URI[md5sum] = "50fc0a2953930ed8d0f6570835e88abf"
+SRC_URI[sha256sum] = "39aa9af22f6558a0c5d132881cf43e34828ca03e4ae11114852ca6a55c7c1d8e"
+
+PYPI_PACKAGE = "sh"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-codecs \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-resource \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-terminal \
+ ${PYTHON_PN}-tests \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-unixadmin \
+"