summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-smpplib_2.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-smpplib_2.1.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-smpplib_2.1.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-smpplib_2.1.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-smpplib_2.1.0.bb
new file mode 100644
index 000000000..15b326bad
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-smpplib_2.1.0.bb
@@ -0,0 +1,24 @@
+SUMMARY = "SMPP library for python"
+SECTION = "devel/python"
+LICENSE = "GPLv3.0"
+LIC_FILES_CHKSUM = "file://README.md;md5=56a03d0ce7e492d4b9487b8aae957efe"
+
+PYPI_PACKAGE = "smpplib"
+SRC_URI[sha256sum] = "df4139a279b35fbb42a58f2a254a9c6daf362b04a7f94e208dc120e0b8a3fd4b"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-unittest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+ sed -i 's/mock/unittest.mock/g' ${D}${PTEST_PATH}/tests/*
+}