summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-stevedore_1.31.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-stevedore_1.31.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-stevedore_1.31.0.bb17
1 files changed, 15 insertions, 2 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-stevedore_1.31.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-stevedore_1.31.0.bb
index 3f557f2cb..b985ca5b1 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-stevedore_1.31.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-stevedore_1.31.0.bb
@@ -1,2 +1,15 @@
-inherit setuptools3
-require python-stevedore.inc
+DESCRIPTION = "Manage dynamic plugins for Python applications"
+HOMEPAGE = "https://github.com/dreamhost/stevedore"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI[md5sum] = "42fa2bf0251c96b543765c5ce13f37c9"
+SRC_URI[sha256sum] = "e0739f9739a681c7a1fda76a102b65295e96a144ccdb552f2ae03c5f0abe8a14"
+
+DEPENDS += "${PYTHON_PN}-pbr-native"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-pbr ${PYTHON_PN}-six"
+
+BBCLASSEXTEND = "native"