summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-wcwidth_0.2.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-wcwidth_0.2.5.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-wcwidth_0.2.5.bb15
1 files changed, 14 insertions, 1 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-wcwidth_0.2.5.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-wcwidth_0.2.5.bb
index 710b35913..bb4aae2e8 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-wcwidth_0.2.5.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-wcwidth_0.2.5.bb
@@ -7,6 +7,19 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=b15979c39a2543892fca8cd86b4b52cb"
SRC_URI[md5sum] = "a07a75f99d316e14838ac760c831ea37"
SRC_URI[sha256sum] = "c4d647b99872929fdb7bdcaa4fbe7f01413ed3d98077df798530e5b04f116c83"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
BBCLASSEXTEND = "native nativesdk"