summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-wtforms_2.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-wtforms_2.3.1.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-wtforms_2.3.1.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-wtforms_2.3.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-wtforms_2.3.1.bb
new file mode 100644
index 000000000..9f081b68c
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-wtforms_2.3.1.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "A flexible forms validation and rendering library for python web development."
+HOMEPAGE = "https://pypi.python.org/pypi/WTForms"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=208ce1c159f911ecf389806650582021"
+
+SRC_URI[md5sum] = "bff06943e59671581af07f80d14bda5f"
+SRC_URI[sha256sum] = "861a13b3ae521d6700dac3b2771970bd354a63ba7043ecc3a82b5288596a1972"
+
+PYPI_PACKAGE = "WTForms"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-numbers \
+ "