summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-xmlschema_1.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-xmlschema_1.6.1.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-xmlschema_1.6.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-xmlschema_1.6.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-xmlschema_1.6.1.bb
new file mode 100644
index 000000000..91697e39a
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-xmlschema_1.6.1.bb
@@ -0,0 +1,19 @@
+SUMMARY = "The xmlschema library is an implementation of XML Schema for Python (supports Python 3.6+)."
+HOMEPAGE = "https://github.com/sissaschool/xmlschema"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=47489cb18c469474afeb259ed1d4832f"
+
+SRC_URI[sha256sum] = "d02b82bb4fce3af09495b85e6ada5ce0cfdaa865b09b28ecc0f5ab81fad7e328"
+
+PYPI_PACKAGE = "xmlschema"
+inherit pypi setuptools3
+
+DEPENDS += "\
+ ${PYTHON_PN}-elementpath-native \
+"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-elementpath \
+"
+
+BBCLASSEXTEND = "native nativesdk"