summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-xxhash_1.4.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-xxhash_1.4.4.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-xxhash_1.4.4.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-xxhash_1.4.4.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-xxhash_1.4.4.bb
new file mode 100644
index 000000000..97f4e358b
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-xxhash_1.4.4.bb
@@ -0,0 +1,22 @@
+SUMMARY = "xxhash is a Python binding for the xxHash library by Yann Collet."
+SECTION = "devel/python"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5a8d76283514a1b7e6a414aba38629b5"
+
+SRC_URI[md5sum] = "0194cc926dd7676d27aba0f89da9798b"
+SRC_URI[sha256sum] = "7d6df9d217977d085b8abd74b61efa40405ac416f2d8bdacc40826bd5cb1b746"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+inherit pypi setuptools3 ptest
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}