summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb31
1 files changed, 29 insertions, 2 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb
index c5df44216..15d92065d 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-yarl_1.4.2.bb
@@ -1,2 +1,29 @@
-inherit setuptools3
-require python-yarl.inc
+SUMMARY = "The module provides handy URL class for url parsing and changing"
+HOMEPAGE = "https://github.com/aio-libs/yarl/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b334fc90d45983db318f54fd5bf6c90b"
+
+SRC_URI[md5sum] = "08ba0d6e18f460b44d9e5459f3d217ba"
+SRC_URI[sha256sum] = "58cd9c469eced558cd81aa3f484b2924e8897049e06889e8ff2510435b7ef74b"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+PYPI_PACKAGE = "yarl"
+
+inherit pypi ptest setuptools3
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-multidict \
+ ${PYTHON_PN}-idna \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}