summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_2.2.0.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_2.1.2.bb)3
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-huey_2.4.1.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-huey_2.4.0.bb)9
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-humanfriendly_10.0.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-humanfriendly_9.2.bb)4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pychromecast_9.2.1.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-pychromecast_9.2.0.bb)2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pyzmq_22.3.0.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-pyzmq_22.2.1.bb)2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-robotframework_4.1.1.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-robotframework_4.1.bb)2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-sqlparse_0.4.2.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-sqlparse_0.4.1.bb)3
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-tqdm_4.62.3.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-tqdm_4.62.2.bb)4
8 files changed, 18 insertions, 11 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_2.1.2.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_2.2.0.bb
index 874e7cf0c..2632ce1c8 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_2.1.2.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_2.2.0.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=4c527bcb481233ebcb803de975f42701"
DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
-SRC_URI[sha256sum] = "25dbb2e9847aaa686a8a21e84e3d101db8b79f5cb992e044fc54210ab8c0ad41"
+SRC_URI[sha256sum] = "34cd12424d9e2835eff125146af3d9f4a4c2931c6bc5a3cea9790bd4f55756d9"
inherit pypi setuptools3
@@ -17,6 +17,7 @@ RDEPENDS:${PN} += "\
${PYTHON_PN}-compression \
${PYTHON_PN}-pydoc \
${PYTHON_PN}-json \
+ ${PYTHON_PN}-numbers \
"
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-huey_2.4.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-huey_2.4.1.bb
index afdc65b24..64bd8880e 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-huey_2.4.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-huey_2.4.1.bb
@@ -5,7 +5,14 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=5cac039fcc82f01141cc170b48f315d4"
PYPI_PACKAGE = "huey"
-SRC_URI[sha256sum] = "82981fb8f1964e8c9ee8f4ebcd5a2ebad561dd93ce8b454bf4f4ecfb54bd1411"
+SRC_URI[sha256sum] = "bd55e90746cec16e7a61d6dc60d4591c74cba59000dca96c387a4d4eee1395f6"
+
+RDEPENDS:${PN} += " \
+ python3-datetime \
+ python3-logging \
+ python3-multiprocessing \
+ python3-json \
+"
inherit pypi setuptools3
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-humanfriendly_9.2.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-humanfriendly_10.0.bb
index d87ed4d2a..7d185989d 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-humanfriendly_9.2.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-humanfriendly_10.0.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5d178009f806c2bdd498a19be0013a7a"
PYPI_PACKAGE = "humanfriendly"
-SRC_URI[sha256sum] = "f7dba53ac7935fd0b4a2fc9a29e316ddd9ea135fb3052d3d0279d10c18ff9c48"
+SRC_URI[sha256sum] = "6b0b831ce8f15f7300721aa49829fc4e83921a9a301cc7f606be6686a2288ddc"
inherit pypi setuptools3
@@ -21,4 +21,4 @@ RDEPENDS:${PN}:class-target += " \
${PYTHON_PN}-stringold \
"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pychromecast_9.2.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pychromecast_9.2.1.bb
index c1f52881a..1fd76ed39 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pychromecast_9.2.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pychromecast_9.2.1.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "https://github.com/balloob/pychromecast"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=b1dbd4e85f47b389bdadee9c694669f5"
-SRC_URI[sha256sum] = "6d34593575cf77565df47af4c75dd47c6a65831ec18a8c10b5367b2f1c172f0a"
+SRC_URI[sha256sum] = "883d6e836ff5f1068a8bd00364a15b4c9854293086495e9fd9cacd9b4d54c0bf"
PYPI_PACKAGE = "PyChromecast"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pyzmq_22.2.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyzmq_22.3.0.bb
index f58074a9a..3c91eee16 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pyzmq_22.2.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyzmq_22.3.0.bb
@@ -8,7 +8,7 @@ DEPENDS = "zeromq"
FILESEXTRAPATHS:prepend := "${THISDIR}/python-pyzmq:"
SRC_URI += "file://club-rpath-out.patch"
-SRC_URI[sha256sum] = "6d18c76676771fd891ca8e0e68da0bbfb88e30129835c0ade748016adb3b6242"
+SRC_URI[sha256sum] = "8eddc033e716f8c91c6a2112f0a8ebc5e00532b4a6ae1eb0ccc48e027f9c671c"
inherit pypi pkgconfig setuptools3
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-robotframework_4.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-robotframework_4.1.1.bb
index 7c6c41af7..d715f3513 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-robotframework_4.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-robotframework_4.1.1.bb
@@ -13,7 +13,7 @@ inherit pypi setuptools3
PYPI_PACKAGE_EXT = "zip"
-SRC_URI[sha256sum] = "567f2a21f0906635e21d45fe3cb84a4809a12980c9f2706a8a5f65f40f6b4ccd"
+SRC_URI[sha256sum] = "663f84c177b2fa9b3b782939e31637a057a33f3a4b29067812f1259b7f4bad35"
RDEPENDS:${PN} += " \
${PYTHON_PN}-shell \
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-sqlparse_0.4.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-sqlparse_0.4.2.bb
index 3565da7d1..0980ff9c2 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-sqlparse_0.4.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-sqlparse_0.4.2.bb
@@ -8,8 +8,7 @@ SRC_URI += "file://0001-sqlparse-change-shebang-to-python3.patch \
file://run-ptest \
"
-SRC_URI[md5sum] = "eebbc6b5f1033054873033e54b0c1266"
-SRC_URI[sha256sum] = "0f91fd2e829c44362cbcfab3e9ae12e22badaa8a29ad5ff599f9ec109f0454e8"
+SRC_URI[sha256sum] = "0c00730c74263a94e5a9919ade150dfc3b19c574389985446148402998287dae"
export BUILD_SYS
export HOST_SYS
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-tqdm_4.62.2.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-tqdm_4.62.3.bb
index bbdd795aa..148431d0a 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-tqdm_4.62.2.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-tqdm_4.62.3.bb
@@ -3,9 +3,9 @@ HOMEPAGE = "http://tqdm.github.io/"
SECTION = "devel/python"
LICENSE = "MIT & MPL-2.0"
-LIC_FILES_CHKSUM = "file://LICENCE;md5=59e4271a933d33edfe60237db377a14b"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=1672e2674934fd93a31c09cf17f34100"
-SRC_URI[sha256sum] = "a4d6d112e507ef98513ac119ead1159d286deab17dffedd96921412c2d236ff5"
+SRC_URI[sha256sum] = "d359de7217506c9851b7869f3708d8ee53ed70a1b8edbba4dbcb47442592920d"
inherit pypi setuptools3