summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-certifi.inc4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-certifi_2019.6.16.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python-certifi_2019.3.9.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-lxml.inc12
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-protobuf.inc4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.8.0.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.6.1.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-twisted.inc4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-twisted_19.2.1.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python-twisted_19.2.0.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-wrapt.inc4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-wrapt_1.11.2.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python-wrapt_1.11.1.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-certifi_2019.6.16.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-certifi_2019.3.9.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf/0001-Add-Python-3.7-compatibility-4862.patch98
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.8.0.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.6.1.bb)1
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-twisted_19.2.1.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-twisted_19.2.0.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-wrapt_1.11.2.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-wrapt_1.11.1.bb)0
14 files changed, 20 insertions, 107 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-certifi.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-certifi.inc
index 9d99b3475..23e18563a 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-certifi.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-certifi.inc
@@ -7,7 +7,7 @@ HOMEPAGE = " http://certifi.io/"
LICENSE = "ISC"
LIC_FILES_CHKSUM = "file://LICENSE;md5=f77f61d14ee6feac4228d3ebd26cc1f1"
-SRC_URI[md5sum] = "76381d19d0a1171fecb2d1002b81424e"
-SRC_URI[sha256sum] = "b26104d6835d1f5e49452a26eb2ff87fe7090b89dfcaee5ea2212697e1e1d7ae"
+SRC_URI[md5sum] = "af8fea5f3df6f7f81e9c6cbc6dd7c1e8"
+SRC_URI[sha256sum] = "945e3ba63a0b9f577b1395204e13c3a231f9bc0223888be653286534e5873695"
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-certifi_2019.3.9.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-certifi_2019.6.16.bb
index adfe6238e..adfe6238e 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-certifi_2019.3.9.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-certifi_2019.6.16.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-lxml.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-lxml.inc
index d67c17883..dd73a412b 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-lxml.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-lxml.inc
@@ -33,6 +33,18 @@ DISTUTILS_INSTALL_ARGS += " \
inherit pypi
+# {standard input}: Assembler messages:
+# {standard input}:1488805: Error: branch out of range
+DEBUG_OPTIMIZATION_remove_mips = " -Og"
+DEBUG_OPTIMIZATION_append_mips = " -O"
+BUILD_OPTIMIZATION_remove_mips = " -Og"
+BUILD_OPTIMIZATION_append_mips = " -O"
+
+DEBUG_OPTIMIZATION_remove_mipsel = " -Og"
+DEBUG_OPTIMIZATION_append_mipsel = " -O"
+BUILD_OPTIMIZATION_remove_mipsel = " -Og"
+BUILD_OPTIMIZATION_append_mipsel = " -O"
+
do_configure_prepend() {
sed -i -e 's/--version/--modversion/' ${B}/setupinfo.py
}
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf.inc
index 54eacc0b7..2929700a0 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf.inc
@@ -7,8 +7,8 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec
inherit pypi
-SRC_URI[md5sum] = "e2daef80e70249aa1f05363670c6b3f8"
-SRC_URI[sha256sum] = "1489b376b0f364bcc6f89519718c057eb191d7ad6f1b395ffd93d1aa45587811"
+SRC_URI[md5sum] = "b7095f3eb736459716d606677b5a29ee"
+SRC_URI[sha256sum] = "8c61cc8a76e9d381c665aecc5105fa0f1878cf7db8b5cd17202603bcb386d0fc"
# http://errors.yoctoproject.org/Errors/Details/184715/
# Can't find required file: ../src/google/protobuf/descriptor.proto
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.6.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.8.0.bb
index f04fc489f..f04fc489f 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.6.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.8.0.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-twisted.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-twisted.inc
index ddef414a1..005aaadef 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-twisted.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-twisted.inc
@@ -7,8 +7,8 @@ HOMEPAGE = "http://www.twistedmatrix.com"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=d136e8cf7b52f2e64079186ae2060d8a"
-SRC_URI[sha256sum] = "1708e1928ae84ec9d3ebab0d427e20e1e38ff721b15bbced476d047d4a43abbe"
-SRC_URI[md5sum] = "473e12f4226e0fecc0ca5698e418e3f6"
+SRC_URI[sha256sum] = "fa2c04c2d68a9be7fc3975ba4947f653a57a656776f24be58ff0fe4b9aaf3e52"
+SRC_URI[md5sum] = "528b7856938edc2a752c244aebd94981"
PYPI_PACKAGE = "Twisted"
PYPI_PACKAGE_EXT = "tar.bz2"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-twisted_19.2.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-twisted_19.2.1.bb
index 5903db3e0..5903db3e0 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-twisted_19.2.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-twisted_19.2.1.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-wrapt.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-wrapt.inc
index 4de09d2fd..ed49811fe 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-wrapt.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-wrapt.inc
@@ -4,8 +4,8 @@ LICENSE = "BSD"
SECTION = "devel/python"
LIC_FILES_CHKSUM = "file://LICENSE;md5=fdfc019b57affbe1d7a32e3d34e83db4"
-SRC_URI[md5sum] = "9f21acd7c0a57bf3057715c4665db3c7"
-SRC_URI[sha256sum] = "4aea003270831cceb8a90ff27c4031da6ead7ec1886023b80ce0dfe0adf61533"
+SRC_URI[md5sum] = "cc15c001b129f81eb2f79b15eb99ffe5"
+SRC_URI[sha256sum] = "565a021fd19419476b9362b05eeaa094178de64f8361e44468f9e9d7843901e1"
inherit pypi
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-wrapt_1.11.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-wrapt_1.11.2.bb
index bb4247657..bb4247657 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-wrapt_1.11.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-wrapt_1.11.2.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-certifi_2019.3.9.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-certifi_2019.6.16.bb
index 70f674b22..70f674b22 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-certifi_2019.3.9.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-certifi_2019.6.16.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf/0001-Add-Python-3.7-compatibility-4862.patch b/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf/0001-Add-Python-3.7-compatibility-4862.patch
deleted file mode 100644
index da5e73b15..000000000
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf/0001-Add-Python-3.7-compatibility-4862.patch
+++ /dev/null
@@ -1,98 +0,0 @@
-From 539bc017a62f91bdf7c547b58948cb5a2f59d918 Mon Sep 17 00:00:00 2001
-From: Ben Webb <ben@salilab.org>
-Date: Thu, 12 Jul 2018 10:58:10 -0700
-Subject: [PATCH] Add Python 3.7 compatibility (#4862)
-
-Compilation of Python wrappers fails with Python 3.7 because
-the Python folks changed their C API such that
-PyUnicode_AsUTF8AndSize() now returns a const char* rather
-than a char*. Add a patch to work around. Relates #4086.
-
-Upstream-Status: Backport [https://github.com/protocolbuffers/protobuf.git]
-Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
-
----
- google/protobuf/pyext/descriptor.cc | 2 +-
- google/protobuf/pyext/descriptor_containers.cc | 2 +-
- google/protobuf/pyext/descriptor_pool.cc | 2 +-
- google/protobuf/pyext/extension_dict.cc | 2 +-
- google/protobuf/pyext/message.cc | 4 ++--
- 5 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/google/protobuf/pyext/descriptor.cc b/google/protobuf/pyext/descriptor.cc
-index 8af0cb1..19a1c38 100644
---- a/google/protobuf/pyext/descriptor.cc
-+++ b/google/protobuf/pyext/descriptor.cc
-@@ -56,7 +56,7 @@
- #endif
- #define PyString_AsStringAndSize(ob, charpp, sizep) \
- (PyUnicode_Check(ob)? \
-- ((*(charpp) = PyUnicode_AsUTF8AndSize(ob, (sizep))) == NULL? -1: 0): \
-+ ((*(charpp) = const_cast<char*>(PyUnicode_AsUTF8AndSize(ob, (sizep)))) == NULL? -1: 0): \
- PyBytes_AsStringAndSize(ob, (charpp), (sizep)))
- #endif
-
-diff --git a/google/protobuf/pyext/descriptor_containers.cc b/google/protobuf/pyext/descriptor_containers.cc
-index bc007f7..0153664 100644
---- a/google/protobuf/pyext/descriptor_containers.cc
-+++ b/google/protobuf/pyext/descriptor_containers.cc
-@@ -66,7 +66,7 @@
- #endif
- #define PyString_AsStringAndSize(ob, charpp, sizep) \
- (PyUnicode_Check(ob)? \
-- ((*(charpp) = PyUnicode_AsUTF8AndSize(ob, (sizep))) == NULL? -1: 0): \
-+ ((*(charpp) = const_cast<char*>(PyUnicode_AsUTF8AndSize(ob, (sizep)))) == NULL? -1: 0): \
- PyBytes_AsStringAndSize(ob, (charpp), (sizep)))
- #endif
-
-diff --git a/google/protobuf/pyext/descriptor_pool.cc b/google/protobuf/pyext/descriptor_pool.cc
-index 95882ae..962accc 100644
---- a/google/protobuf/pyext/descriptor_pool.cc
-+++ b/google/protobuf/pyext/descriptor_pool.cc
-@@ -48,7 +48,7 @@
- #endif
- #define PyString_AsStringAndSize(ob, charpp, sizep) \
- (PyUnicode_Check(ob)? \
-- ((*(charpp) = PyUnicode_AsUTF8AndSize(ob, (sizep))) == NULL? -1: 0): \
-+ ((*(charpp) = const_cast<char*>(PyUnicode_AsUTF8AndSize(ob, (sizep)))) == NULL? -1: 0): \
- PyBytes_AsStringAndSize(ob, (charpp), (sizep)))
- #endif
-
-diff --git a/google/protobuf/pyext/extension_dict.cc b/google/protobuf/pyext/extension_dict.cc
-index 018b5c2..174c547 100644
---- a/google/protobuf/pyext/extension_dict.cc
-+++ b/google/protobuf/pyext/extension_dict.cc
-@@ -53,7 +53,7 @@
- #endif
- #define PyString_AsStringAndSize(ob, charpp, sizep) \
- (PyUnicode_Check(ob)? \
-- ((*(charpp) = PyUnicode_AsUTF8AndSize(ob, (sizep))) == NULL? -1: 0): \
-+ ((*(charpp) = const_cast<char*>(PyUnicode_AsUTF8AndSize(ob, (sizep)))) == NULL? -1: 0): \
- PyBytes_AsStringAndSize(ob, (charpp), (sizep)))
- #endif
-
-diff --git a/google/protobuf/pyext/message.cc b/google/protobuf/pyext/message.cc
-index 5893533..31094b7 100644
---- a/google/protobuf/pyext/message.cc
-+++ b/google/protobuf/pyext/message.cc
-@@ -79,7 +79,7 @@
- (PyUnicode_Check(ob)? PyUnicode_AsUTF8(ob): PyBytes_AsString(ob))
- #define PyString_AsStringAndSize(ob, charpp, sizep) \
- (PyUnicode_Check(ob)? \
-- ((*(charpp) = PyUnicode_AsUTF8AndSize(ob, (sizep))) == NULL? -1: 0): \
-+ ((*(charpp) = const_cast<char*>(PyUnicode_AsUTF8AndSize(ob, (sizep)))) == NULL? -1: 0): \
- PyBytes_AsStringAndSize(ob, (charpp), (sizep)))
- #endif
- #endif
-@@ -1529,7 +1529,7 @@ PyObject* HasField(CMessage* self, PyObject* arg) {
- return NULL;
- }
- #else
-- field_name = PyUnicode_AsUTF8AndSize(arg, &size);
-+ field_name = const_cast<char*>(PyUnicode_AsUTF8AndSize(arg, &size));
- if (!field_name) {
- return NULL;
- }
---
-2.7.4
-
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.6.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.8.0.bb
index 9b0668a02..30ea34e90 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.6.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.8.0.bb
@@ -1,7 +1,6 @@
inherit setuptools3
require python-protobuf.inc
-SRC_URI += "file://0001-Add-Python-3.7-compatibility-4862.patch"
DEPENDS += "protobuf"
DISTUTILS_BUILD_ARGS += "--cpp_implementation"
DISTUTILS_INSTALL_ARGS += "--cpp_implementation"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-twisted_19.2.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-twisted_19.2.1.bb
index dfb9d4a4c..dfb9d4a4c 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-twisted_19.2.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-twisted_19.2.1.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-wrapt_1.11.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-wrapt_1.11.2.bb
index 85f446ef9..85f446ef9 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-wrapt_1.11.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-wrapt_1.11.2.bb