summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-flask-pymongo.inc6
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-flask-pymongo_2.3.0.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python-flask-pymongo_0.5.1.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-protobuf.inc4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.9.1.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.9.0.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-socketio.inc6
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-flask-pymongo_2.3.0.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-flask-pymongo_0.5.1.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.9.1.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.9.0.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-socketio_4.3.1.bb2
8 files changed, 11 insertions, 7 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-flask-pymongo.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-flask-pymongo.inc
index fb2d6ed8b..39251525b 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-flask-pymongo.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-flask-pymongo.inc
@@ -5,9 +5,11 @@ SECTION = "devel/python"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://flask_pymongo/wrappers.py;beginline=1;endline=24;md5=424c4e1047d28e01b4e4634a069c019d"
-SRC_URI[md5sum] = "d7a1b717f27154e1f3a355f8ec2467d6"
-SRC_URI[sha256sum] = "2baaa2ba5107d72b3a8bd4b5c0c8881316e35340ad1ae979cc13f1f3c8843b3d"
+SRC_URI[md5sum] = "94df71e6800b1d7915cc91a74b70f959"
+SRC_URI[sha256sum] = "620eb02dc8808a5fcb90f26cab6cba9d6bf497b15032ae3ca99df80366e33314"
PYPI_PACKAGE = "Flask-PyMongo"
+DEPENDS = "${PYTHON_PN}-vcversioner ${PYTHON_PN}-vcversioner-native"
+
RDEPENDS_${PN} = "${PYTHON_PN}-pymongo ${PYTHON_PN}-flask"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-flask-pymongo_0.5.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-flask-pymongo_2.3.0.bb
index d41d02348..d41d02348 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-flask-pymongo_0.5.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-flask-pymongo_2.3.0.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf.inc
index b13f10e36..ce95e66c9 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf.inc
@@ -7,8 +7,8 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec
inherit pypi
-SRC_URI[md5sum] = "4ec7b2d49a5d1460591e520b54153c87"
-SRC_URI[sha256sum] = "b3452bbda12b1cbe2187d416779de07b2ab4c497d83a050e43c344778763721d"
+SRC_URI[md5sum] = "ca881f18795e024a2b935d5bae9b1ebe"
+SRC_URI[sha256sum] = "d831b047bd69becaf64019a47179eb22118a50dd008340655266a906c69c6417"
# http://errors.yoctoproject.org/Errors/Details/184715/
# Can't find required file: ../src/google/protobuf/descriptor.proto
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.9.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.9.1.bb
index f04fc489f..f04fc489f 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.9.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.9.1.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-socketio.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-socketio.inc
index 7ebc4eac7..7ee99f8d9 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-socketio.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-socketio.inc
@@ -12,9 +12,9 @@ PYPI_PACKAGE = "python-socketio"
SRC_URI[md5sum] = "86cd47dddea1785ce7a6c72f55c93fe7"
SRC_URI[sha256sum] = "506b2cf7a520b40ea0b3f25e1272eff8de134dce6f471c1f6bc0de8c90fe8c57"
-PACKAGECONFIG ?= "asyncio_client client"
-PACKAGECONFIG[asyncio_client] = ",,,python3-aiohttp python3-websockets"
-PACKAGECONFIG[client] = ",,,python3-requests python3-websocket-client"
+PACKAGECONFIG ?= ""
+PACKAGECONFIG[asyncio_client] = ",,,${PYTHON_PN}-aiohttp ${PYTHON_PN}-websockets"
+PACKAGECONFIG[client] = ",,,${PYTHON_PN}-requests ${PYTHON_PN}-websocket-client"
RDEPENDS_${PN} += "\
${PYTHON_PN}-engineio \
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-flask-pymongo_0.5.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-flask-pymongo_2.3.0.bb
index 2102554b6..2102554b6 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-flask-pymongo_0.5.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-flask-pymongo_2.3.0.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.9.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.9.1.bb
index 30ea34e90..30ea34e90 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.9.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.9.1.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-socketio_4.3.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-socketio_4.3.1.bb
index ce83d09c0..8ff590bd7 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-socketio_4.3.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-socketio_4.3.1.bb
@@ -1,2 +1,4 @@
inherit setuptools3
+
+PACKAGECONFIG ?= "asyncio_client client"
require python-socketio.inc