summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-dbus_1.2.12.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python-dbus_1.2.10.bb)4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pluggy.inc4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pluggy_0.13.0.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python-pluggy_0.12.0.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pyserial.inc2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pyusb.inc2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pluggy_0.13.0.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-pluggy_0.12.0.bb)0
6 files changed, 8 insertions, 4 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-dbus_1.2.10.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-dbus_1.2.12.bb
index 9907ea953..f08fa20a1 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-dbus_1.2.10.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-dbus_1.2.12.bb
@@ -9,8 +9,8 @@ DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native"
SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
"
-SRC_URI[md5sum] = "5d21d5ae6423f0e41caa3400af44edac"
-SRC_URI[sha256sum] = "d4332bbd4a0054fa4010b259c293b84d461bbd9d7a8ef528157d151c0398d886"
+SRC_URI[md5sum] = "428b7a9e7e2d154a7ceb3e13536283e4"
+SRC_URI[sha256sum] = "cdd4de2c4f5e58f287b12013ed7b41dee81d503c8d0d2397c5bd2fb01badf260"
S = "${WORKDIR}/dbus-python-${PV}"
inherit distutils-base autotools pkgconfig
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pluggy.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-pluggy.inc
index c9bee6287..57660060c 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-pluggy.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pluggy.inc
@@ -3,8 +3,8 @@ HOMEPAGE = "https://github.com/pytest-dev/pluggy"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=1c8206d16fd5cc02fa9b0bb98955e5c2"
-SRC_URI[md5sum] = "e986647f5d786c0cc1bd065cf9bac658"
-SRC_URI[sha256sum] = "0825a152ac059776623854c1543d65a4ad408eb3d33ee114dff91e57ec6ae6fc"
+SRC_URI[md5sum] = "4b8384b69cddbc2e104fdd3ff5631788"
+SRC_URI[sha256sum] = "fa5fa1622fa6dd5c030e9cad086fa19ef6a0cf6d7a2d12318e10cb49d6d68f34"
DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pluggy_0.12.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-pluggy_0.13.0.bb
index edcd4f512..edcd4f512 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-pluggy_0.12.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pluggy_0.13.0.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pyserial.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-pyserial.inc
index 52a7e05ce..870f1d8a8 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-pyserial.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pyserial.inc
@@ -40,3 +40,5 @@ RDEPENDS_${PN} = "\
${PYTHON_PN}-stringold \
${PYTHON_PN}-threading \
"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pyusb.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-pyusb.inc
index 30bbe85a9..baf2db530 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-pyusb.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pyusb.inc
@@ -8,3 +8,5 @@ SRC_URI[md5sum] = "862b56452c64948c787ad8ef9498590b"
SRC_URI[sha256sum] = "4e9b72cc4a4205ca64fbf1f3fff39a335512166c151ad103e55c8223ac147362"
inherit pypi
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pluggy_0.12.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pluggy_0.13.0.bb
index 941e8e3d8..941e8e3d8 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pluggy_0.12.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pluggy_0.13.0.bb