summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-extended/pywbem
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-extended/pywbem')
-rw-r--r--meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_0.15.0.bb9
-rw-r--r--meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_1.1.0.bb (renamed from meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem.inc)19
2 files changed, 8 insertions, 20 deletions
diff --git a/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_0.15.0.bb b/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_0.15.0.bb
deleted file mode 100644
index abfb8d920..000000000
--- a/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_0.15.0.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require python-pywbem.inc
-inherit setuptools3 update-alternatives
-
-ALTERNATIVE_${PN} = "mof_compiler pywbemcli wbemcli"
-ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler"
-ALTERNATIVE_TARGET[pywbemcli] = "${bindir}/pywbemcli"
-ALTERNATIVE_TARGET[wbemcli] = "${bindir}/wbemcli"
-
-ALTERNATIVE_PRIORITY = "60"
diff --git a/meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem.inc b/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_1.1.0.bb
index 98508b0c3..d68ae9abf 100644
--- a/meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem.inc
+++ b/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_1.1.0.bb
@@ -16,12 +16,10 @@ HOMEPAGE = "http://pywbem.github.io"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fbc093901857fcd118f065f900982c24"
-inherit pypi
+SRC_URI[md5sum] = "6ade0cda6a997542d61f15713c2dd971"
+SRC_URI[sha256sum] = "4e2baa4b4b88943cca32c7eb588fffff22ce86c748ba7544e01149f9638014fe"
-SRCREV = "b3386b3bee8876d15f0745147c0b08937d8ab18e"
-PYPI_SRC_URI = "git://github.com/pywbem/pywbem;protocol=https;branch=stable_0.15"
-
-S = "${WORKDIR}/git"
+inherit pypi setuptools3 update-alternatives
DEPENDS += " \
${PYTHON_PN}-ply-native \
@@ -29,12 +27,6 @@ DEPENDS += " \
${PYTHON_PN}-six-native \
"
-do_install_append() {
- mv ${D}${bindir}/wbemcli.py ${D}${bindir}/pywbemcli
-
- rm -f ${D}${bindir}/*.bat
-}
-
RDEPENDS_${PN}_class-target += "\
${PYTHON_PN}-datetime \
${PYTHON_PN}-io \
@@ -48,4 +40,9 @@ RDEPENDS_${PN}_class-target += "\
${PYTHON_PN}-xml \
"
+ALTERNATIVE_${PN} = "mof_compiler"
+ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler"
+
+ALTERNATIVE_PRIORITY = "60"
+
BBCLASSEXTEND = "native"