summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-extended')
-rw-r--r--meta-openembedded/meta-python/recipes-extended/python-meh/python3-meh_0.49.bb (renamed from meta-openembedded/meta-python/recipes-extended/python-meh/python3-meh_0.48.bb)4
-rw-r--r--meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_1.0.2.bb (renamed from meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_0.17.4.bb)14
-rw-r--r--meta-openembedded/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_0.7.1.bb40
3 files changed, 45 insertions, 13 deletions
diff --git a/meta-openembedded/meta-python/recipes-extended/python-meh/python3-meh_0.48.bb b/meta-openembedded/meta-python/recipes-extended/python-meh/python3-meh_0.49.bb
index 9ca7a56bd..7fba21f7d 100644
--- a/meta-openembedded/meta-python/recipes-extended/python-meh/python3-meh_0.48.bb
+++ b/meta-openembedded/meta-python/recipes-extended/python-meh/python3-meh_0.49.bb
@@ -3,6 +3,7 @@ DESCRIPTION = "The python-meh package is a python library for handling, saving,
exceptions."
HOMEPAGE = "http://git.fedorahosted.org/git/?p=python-meh.git"
LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
inherit setuptools3
@@ -10,8 +11,7 @@ S = "${WORKDIR}/git"
SRC_URI = "git://github.com/rhinstaller/python-meh.git;protocol=https;branch=master \
"
-SRCREV = "760f78a634ecf0e2380abcbd751bc233d29300ef"
-LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+SRCREV = "50c09e5c4c76757099d686c316b4bf42f72db71b"
FILES_${PN} += "${datadir}/*"
diff --git a/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_0.17.4.bb b/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_1.0.2.bb
index a804b0cc0..da731989d 100644
--- a/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_0.17.4.bb
+++ b/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_1.0.2.bb
@@ -16,8 +16,8 @@ HOMEPAGE = "http://pywbem.github.io"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fbc093901857fcd118f065f900982c24"
-SRC_URI[md5sum] = "b65c03026bf2174e58e3e47a5e7e4825"
-SRC_URI[sha256sum] = "5b54b65a5434bb16432415743c0d154feee0c6d7a8a2fee208719c67d6d24c97"
+SRC_URI[md5sum] = "0f171e365e294554f8e7624ccf511067"
+SRC_URI[sha256sum] = "66d8ec82d30f2b95d8b4bd51659429066c2879d3f46292561f5fdbc7fed10f3d"
inherit pypi setuptools3 update-alternatives
@@ -27,12 +27,6 @@ DEPENDS += " \
${PYTHON_PN}-six-native \
"
-do_install_append() {
- mv ${D}${bindir}/wbemcli.py ${D}${bindir}/pywbemcli
-
- rm -f ${D}${bindir}/*.bat
-}
-
RDEPENDS_${PN}_class-target += "\
${PYTHON_PN}-datetime \
${PYTHON_PN}-io \
@@ -46,10 +40,8 @@ RDEPENDS_${PN}_class-target += "\
${PYTHON_PN}-xml \
"
-ALTERNATIVE_${PN} = "mof_compiler pywbemcli wbemcli"
+ALTERNATIVE_${PN} = "mof_compiler"
ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler"
-ALTERNATIVE_TARGET[pywbemcli] = "${bindir}/pywbemcli"
-ALTERNATIVE_TARGET[wbemcli] = "${bindir}/wbemcli"
ALTERNATIVE_PRIORITY = "60"
diff --git a/meta-openembedded/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_0.7.1.bb b/meta-openembedded/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_0.7.1.bb
new file mode 100644
index 000000000..05f77288e
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_0.7.1.bb
@@ -0,0 +1,40 @@
+SUMMARY = "A set of tools using pywbem"
+DESCRIPTION = "A set of tools using pywbem to communicate with WBEM servers"
+HOMEPAGE = "https://pywbemtools.readthedocs.io/en/stable/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa"
+
+SRC_URI[md5sum] = "a789da735c04ddc08ba828cd8022243e"
+SRC_URI[sha256sum] = "d2fe776c78a740215142f4f033055093f2283fd9327440c59734716e51e19989"
+
+inherit pypi setuptools3
+
+DEPENDS += " \
+ ${PYTHON_PN}-pyyaml-native \
+ ${PYTHON_PN}-pywbem-native \
+ ${PYTHON_PN}-six-native \
+ ${PYTHON_PN}-click-native \
+"
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-ply \
+ ${PYTHON_PN}-pyyaml \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-pywbem \
+ ${PYTHON_PN}-click \
+ ${PYTHON_PN}-requests \
+ ${PYTHON_PN}-prompt-toolkit \
+ ${PYTHON_PN}-mock \
+ ${PYTHON_PN}-packaging \
+ ${PYTHON_PN}-nocasedict \
+ ${PYTHON_PN}-yamlloader \
+ ${PYTHON_PN}-click-repl \
+ ${PYTHON_PN}-click-spinner \
+ ${PYTHON_PN}-asciitree \
+ ${PYTHON_PN}-tabulate \
+ ${PYTHON_PN}-pydicti \
+ ${PYTHON_PN}-nocaselist \
+ ${PYTHON_PN}-custom-inherit \
+"
+
+BBCLASSEXTEND = "native"