summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-extended')
-rw-r--r--meta-openembedded/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb2
-rw-r--r--meta-openembedded/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb2
-rw-r--r--meta-openembedded/meta-python/recipes-extended/python-meh/python3-meh_0.48.bb (renamed from meta-openembedded/meta-python/recipes-extended/python-meh/python3-meh_0.47.bb)2
-rw-r--r--meta-openembedded/meta-python/recipes-extended/python-pyephem/python-pyephem_3.7.7.0.bb (renamed from meta-openembedded/meta-python/recipes-extended/python-pyephem/python-pyephem_3.7.6.0.bb)4
-rw-r--r--meta-openembedded/meta-python/recipes-extended/python-pykickstart/files/0003-comment-out-sections-shutdown-and-environment-in-gen.patch10
-rw-r--r--meta-openembedded/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.22.bb (renamed from meta-openembedded/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.20.bb)2
-rw-r--r--meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted.inc2
-rw-r--r--meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.3.bb (renamed from meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.2.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb (renamed from meta-openembedded/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.2.bb)0
9 files changed, 12 insertions, 12 deletions
diff --git a/meta-openembedded/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb b/meta-openembedded/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb
index fe9d27ab8..2b5b253b5 100644
--- a/meta-openembedded/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb
+++ b/meta-openembedded/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb
@@ -25,7 +25,7 @@ SRC_URI = "git://github.com/rhinstaller/blivet;branch=3.1-release \
UPSTREAM_CHECK_GITTAGREGEX = "blivet-(?P<pver>\d+(\.\d+)+)$"
-inherit distro_features_check
+inherit features_check
REQUIRED_DISTRO_FEATURES = "systemd"
inherit setuptools3 python3native
diff --git a/meta-openembedded/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb b/meta-openembedded/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb
index b7e2493c3..92402bee5 100644
--- a/meta-openembedded/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb
+++ b/meta-openembedded/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb
@@ -13,7 +13,7 @@ SRC_URI = "git://github.com/rhinstaller/blivet-gui;branch=master \
file://0001-Fix-return-type-of-BlivetUtils.get_disks-1658893.patch \
"
-inherit distro_features_check
+inherit features_check
REQUIRED_DISTRO_FEATURES = "x11 systemd"
inherit setuptools3 python3native
diff --git a/meta-openembedded/meta-python/recipes-extended/python-meh/python3-meh_0.47.bb b/meta-openembedded/meta-python/recipes-extended/python-meh/python3-meh_0.48.bb
index 95d6d183c..9ca7a56bd 100644
--- a/meta-openembedded/meta-python/recipes-extended/python-meh/python3-meh_0.47.bb
+++ b/meta-openembedded/meta-python/recipes-extended/python-meh/python3-meh_0.48.bb
@@ -10,7 +10,7 @@ S = "${WORKDIR}/git"
SRC_URI = "git://github.com/rhinstaller/python-meh.git;protocol=https;branch=master \
"
-SRCREV = "78d868d99104317ce8820f39f61d207566e61a55"
+SRCREV = "760f78a634ecf0e2380abcbd751bc233d29300ef"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
FILES_${PN} += "${datadir}/*"
diff --git a/meta-openembedded/meta-python/recipes-extended/python-pyephem/python-pyephem_3.7.6.0.bb b/meta-openembedded/meta-python/recipes-extended/python-pyephem/python-pyephem_3.7.7.0.bb
index e28ce6ccc..422f0dbc4 100644
--- a/meta-openembedded/meta-python/recipes-extended/python-pyephem/python-pyephem_3.7.6.0.bb
+++ b/meta-openembedded/meta-python/recipes-extended/python-pyephem/python-pyephem_3.7.7.0.bb
@@ -4,8 +4,8 @@ HOMEPAGE = "http://rhodesmill.org/pyephem/"
LICENSE = "LGPL-3.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=f288303760f6e5ceaafe3aaa32186ab1"
-SRC_URI[md5sum] = "405a109f3017251ecd8c2890d850f649"
-SRC_URI[sha256sum] = "7a4c82b1def2893e02aec0394f108d24adb17bd7b0ca6f4bc78eb7120c0212ac"
+SRC_URI[md5sum] = "46c035b4a903ff26e0d8ad0f1fe6cc35"
+SRC_URI[sha256sum] = "607148429f85412915e32265779c0cf6d09f73aa97cf1ff0d101ac22c69c4436"
PYPI_PACKAGE = "ephem"
diff --git a/meta-openembedded/meta-python/recipes-extended/python-pykickstart/files/0003-comment-out-sections-shutdown-and-environment-in-gen.patch b/meta-openembedded/meta-python/recipes-extended/python-pykickstart/files/0003-comment-out-sections-shutdown-and-environment-in-gen.patch
index 81e351b11..7ab734686 100644
--- a/meta-openembedded/meta-python/recipes-extended/python-pykickstart/files/0003-comment-out-sections-shutdown-and-environment-in-gen.patch
+++ b/meta-openembedded/meta-python/recipes-extended/python-pykickstart/files/0003-comment-out-sections-shutdown-and-environment-in-gen.patch
@@ -17,7 +17,7 @@ fixup! add comments of shutdown for user
2 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/pykickstart/commands/reboot.py b/pykickstart/commands/reboot.py
-index 2c1b1c0..b3ec717 100644
+index 75a6d916..edfe83ff 100644
--- a/pykickstart/commands/reboot.py
+++ b/pykickstart/commands/reboot.py
@@ -43,6 +43,9 @@ class FC3_Reboot(KickstartCommand):
@@ -31,18 +31,18 @@ index 2c1b1c0..b3ec717 100644
return retval
diff --git a/pykickstart/parser.py b/pykickstart/parser.py
-index e68174d..efd78a6 100644
+index bc59131b..b2d09d45 100644
--- a/pykickstart/parser.py
+++ b/pykickstart/parser.py
-@@ -385,7 +385,7 @@ class Packages(KickstartObject):
+@@ -428,7 +428,7 @@ class Packages(KickstartObject):
if not self.default:
if self.environment:
- pkgs += "@^%s\n" % self.environment
+ pkgs += "#@^%s\n" % self.environment
- grps = self.groupList
- grps.sort()
+ grps = self.groupList
+ grps.sort()
--
2.7.4
diff --git a/meta-openembedded/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.20.bb b/meta-openembedded/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.22.bb
index ed10ce958..041abd3e8 100644
--- a/meta-openembedded/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.20.bb
+++ b/meta-openembedded/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.22.bb
@@ -18,7 +18,7 @@ SRC_URI = "git://github.com/rhinstaller/pykickstart.git;protocol=https;branch=ma
file://0003-comment-out-sections-shutdown-and-environment-in-gen.patch \
file://0004-load.py-retry-to-invoke-request-with-timeout.patch \
"
-SRCREV = "487edfded19d5969db0673b200ee4272b7dc6697"
+SRCREV = "674c17b1e231f56a0d8a5ced4a204cdbc4c1edf3"
UPSTREAM_CHECK_GITTAGREGEX = "r(?P<pver>\d+(\.\d+)+(-\d+)*)"
diff --git a/meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted.inc b/meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted.inc
index f769f95a0..97054487f 100644
--- a/meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted.inc
+++ b/meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted.inc
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "\
DEPENDS += "parted"
# upstream only publishes releases in github archives which are discouraged
-SRCREV = "2396ba7df56de277b4999bdd5f7d1a1706a6388a"
+SRCREV = "481510c10866851844b19f3d2ffcdaa37efc0cf8"
SRC_URI = "git://github.com/rhinstaller/pyparted.git;protocol=https"
S = "${WORKDIR}/git"
diff --git a/meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.2.bb b/meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.3.bb
index 32aa378cc..32aa378cc 100644
--- a/meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.2.bb
+++ b/meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.3.bb
diff --git a/meta-openembedded/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.2.bb b/meta-openembedded/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb
index d83901ff3..d83901ff3 100644
--- a/meta-openembedded/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.2.bb
+++ b/meta-openembedded/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb