summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-extended')
-rw-r--r--meta-openembedded/meta-python/recipes-extended/python-meh/python3-meh_0.49.bb (renamed from meta-openembedded/meta-python/recipes-extended/python-meh/python3-meh_0.48.bb)4
-rw-r--r--meta-openembedded/meta-python/recipes-extended/python-pykickstart/files/0001-support-authentication-for-kickstart.patch10
-rw-r--r--meta-openembedded/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.26.bb (renamed from meta-openembedded/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.22.bb)2
-rw-r--r--meta-openembedded/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb8
-rw-r--r--meta-openembedded/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.7.bb (renamed from meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted.inc)13
-rw-r--r--meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_0.15.0.bb9
-rw-r--r--meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_1.1.0.bb (renamed from meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem.inc)19
-rw-r--r--meta-openembedded/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_0.8.0.bb40
8 files changed, 64 insertions, 41 deletions
diff --git a/meta-openembedded/meta-python/recipes-extended/python-meh/python3-meh_0.48.bb b/meta-openembedded/meta-python/recipes-extended/python-meh/python3-meh_0.49.bb
index 9ca7a56bd..7fba21f7d 100644
--- a/meta-openembedded/meta-python/recipes-extended/python-meh/python3-meh_0.48.bb
+++ b/meta-openembedded/meta-python/recipes-extended/python-meh/python3-meh_0.49.bb
@@ -3,6 +3,7 @@ DESCRIPTION = "The python-meh package is a python library for handling, saving,
exceptions."
HOMEPAGE = "http://git.fedorahosted.org/git/?p=python-meh.git"
LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
inherit setuptools3
@@ -10,8 +11,7 @@ S = "${WORKDIR}/git"
SRC_URI = "git://github.com/rhinstaller/python-meh.git;protocol=https;branch=master \
"
-SRCREV = "760f78a634ecf0e2380abcbd751bc233d29300ef"
-LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+SRCREV = "50c09e5c4c76757099d686c316b4bf42f72db71b"
FILES_${PN} += "${datadir}/*"
diff --git a/meta-openembedded/meta-python/recipes-extended/python-pykickstart/files/0001-support-authentication-for-kickstart.patch b/meta-openembedded/meta-python/recipes-extended/python-pykickstart/files/0001-support-authentication-for-kickstart.patch
index e7533f476..0e64ce420 100644
--- a/meta-openembedded/meta-python/recipes-extended/python-pykickstart/files/0001-support-authentication-for-kickstart.patch
+++ b/meta-openembedded/meta-python/recipes-extended/python-pykickstart/files/0001-support-authentication-for-kickstart.patch
@@ -32,10 +32,10 @@ index bf08ac5..aada7aa 100644
And some warning classes:
KickstartWarning - A generic warning class.
-@@ -131,3 +134,17 @@ class KickstartDeprecationWarning(KickstartParseWarning, DeprecationWarning):
+@@ -125,3 +128,17 @@ class KickstartDeprecationWarning(KickstartParseWarning, DeprecationWarning):
+ """A class for warnings occurring during parsing related to using deprecated
commands and options.
"""
- pass
+
+class KickstartAuthError(KickstartError):
+ """An exception for errors relating to authentication failed while
@@ -43,7 +43,7 @@ index bf08ac5..aada7aa 100644
+ """
+ def __init__(self, msg):
+ """Create a new KickstartAuthError exception instance with the
-+ descriptive message val. val should be the return value of
++ descriptive message val. val should be the return value of
+ formatErrorMsg.
+ """
+ KickstartError.__init__(self, msg)
@@ -125,7 +125,7 @@ diff --git a/pykickstart/parser.py b/pykickstart/parser.py
index d8880eb..22d14cb 100644
--- a/pykickstart/parser.py
+++ b/pykickstart/parser.py
-@@ -787,7 +787,7 @@ class KickstartParser(object):
+@@ -801,7 +801,7 @@ class KickstartParser(object):
i = PutBackIterator(s.splitlines(True) + [""])
self._stateMachine(i)
@@ -134,7 +134,7 @@ index d8880eb..22d14cb 100644
"""Process a kickstart file, given by the filename f."""
if reset:
self._reset()
-@@ -808,7 +808,7 @@ class KickstartParser(object):
+@@ -822,7 +822,7 @@ class KickstartParser(object):
self.currentdir[self._includeDepth] = cd
try:
diff --git a/meta-openembedded/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.22.bb b/meta-openembedded/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.26.bb
index 041abd3e8..7aeb5d6c9 100644
--- a/meta-openembedded/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.22.bb
+++ b/meta-openembedded/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.26.bb
@@ -18,7 +18,7 @@ SRC_URI = "git://github.com/rhinstaller/pykickstart.git;protocol=https;branch=ma
file://0003-comment-out-sections-shutdown-and-environment-in-gen.patch \
file://0004-load.py-retry-to-invoke-request-with-timeout.patch \
"
-SRCREV = "674c17b1e231f56a0d8a5ced4a204cdbc4c1edf3"
+SRCREV = "4c93e84c8798da511da1c05f1912d2f908f8f85f"
UPSTREAM_CHECK_GITTAGREGEX = "r(?P<pver>\d+(\.\d+)+(-\d+)*)"
diff --git a/meta-openembedded/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb b/meta-openembedded/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb
deleted file mode 100644
index d83901ff3..000000000
--- a/meta-openembedded/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.3.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-require python-pyparted.inc
-
-inherit distutils3
-
-RDEPENDS_${PN} += "python3-stringold python3-codecs python3-math"
-RDEPENDS_${PN}_class-native = ""
-
-BBCLASSEXTEND = "native"
diff --git a/meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted.inc b/meta-openembedded/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.7.bb
index 97054487f..8909aa11f 100644
--- a/meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted.inc
+++ b/meta-openembedded/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.7.bb
@@ -8,15 +8,18 @@ LIC_FILES_CHKSUM = "\
file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
file://src/_pedmodule.c;beginline=10;endline=22;md5=9e53304db812b80d0939e11bb69dcab2 \
"
-DEPENDS += "parted"
-# upstream only publishes releases in github archives which are discouraged
-SRCREV = "481510c10866851844b19f3d2ffcdaa37efc0cf8"
-SRC_URI = "git://github.com/rhinstaller/pyparted.git;protocol=https"
+SRC_URI[md5sum] = "69284f943982f54ded76960c92098a02"
+SRC_URI[sha256sum] = "61cde7b096bccd69ddc75c85b17f8baed45c3687d404706d91403a319453b903"
+
+inherit pypi distutils3
-S = "${WORKDIR}/git"
+DEPENDS += "parted"
RDEPENDS_${PN}_class-target += " \
parted (>= 2.3) \
+ python3-stringold python3-codecs python3-math \
"
RDEPENDS_${PN}_class-native = ""
+
+BBCLASSEXTEND = "native"
diff --git a/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_0.15.0.bb b/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_0.15.0.bb
deleted file mode 100644
index abfb8d920..000000000
--- a/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_0.15.0.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require python-pywbem.inc
-inherit setuptools3 update-alternatives
-
-ALTERNATIVE_${PN} = "mof_compiler pywbemcli wbemcli"
-ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler"
-ALTERNATIVE_TARGET[pywbemcli] = "${bindir}/pywbemcli"
-ALTERNATIVE_TARGET[wbemcli] = "${bindir}/wbemcli"
-
-ALTERNATIVE_PRIORITY = "60"
diff --git a/meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem.inc b/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_1.1.0.bb
index 98508b0c3..d68ae9abf 100644
--- a/meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem.inc
+++ b/meta-openembedded/meta-python/recipes-extended/pywbem/python3-pywbem_1.1.0.bb
@@ -16,12 +16,10 @@ HOMEPAGE = "http://pywbem.github.io"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fbc093901857fcd118f065f900982c24"
-inherit pypi
+SRC_URI[md5sum] = "6ade0cda6a997542d61f15713c2dd971"
+SRC_URI[sha256sum] = "4e2baa4b4b88943cca32c7eb588fffff22ce86c748ba7544e01149f9638014fe"
-SRCREV = "b3386b3bee8876d15f0745147c0b08937d8ab18e"
-PYPI_SRC_URI = "git://github.com/pywbem/pywbem;protocol=https;branch=stable_0.15"
-
-S = "${WORKDIR}/git"
+inherit pypi setuptools3 update-alternatives
DEPENDS += " \
${PYTHON_PN}-ply-native \
@@ -29,12 +27,6 @@ DEPENDS += " \
${PYTHON_PN}-six-native \
"
-do_install_append() {
- mv ${D}${bindir}/wbemcli.py ${D}${bindir}/pywbemcli
-
- rm -f ${D}${bindir}/*.bat
-}
-
RDEPENDS_${PN}_class-target += "\
${PYTHON_PN}-datetime \
${PYTHON_PN}-io \
@@ -48,4 +40,9 @@ RDEPENDS_${PN}_class-target += "\
${PYTHON_PN}-xml \
"
+ALTERNATIVE_${PN} = "mof_compiler"
+ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler"
+
+ALTERNATIVE_PRIORITY = "60"
+
BBCLASSEXTEND = "native"
diff --git a/meta-openembedded/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_0.8.0.bb b/meta-openembedded/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_0.8.0.bb
new file mode 100644
index 000000000..03caec539
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-extended/pywbemtools/python3-pywbemtools_0.8.0.bb
@@ -0,0 +1,40 @@
+SUMMARY = "A set of tools using pywbem"
+DESCRIPTION = "A set of tools using pywbem to communicate with WBEM servers"
+HOMEPAGE = "https://pywbemtools.readthedocs.io/en/stable/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa"
+
+SRC_URI[md5sum] = "e41ef654a0af0461d6c164752963fdfb"
+SRC_URI[sha256sum] = "b869bb217613cdfee1e97e8afc28fe3f9bf3b88f8fc99e588d03c4be0922c319"
+
+inherit pypi setuptools3
+
+DEPENDS += " \
+ ${PYTHON_PN}-pyyaml-native \
+ ${PYTHON_PN}-pywbem-native \
+ ${PYTHON_PN}-six-native \
+ ${PYTHON_PN}-click-native \
+"
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-ply \
+ ${PYTHON_PN}-pyyaml \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-pywbem \
+ ${PYTHON_PN}-click \
+ ${PYTHON_PN}-requests \
+ ${PYTHON_PN}-prompt-toolkit \
+ ${PYTHON_PN}-mock \
+ ${PYTHON_PN}-packaging \
+ ${PYTHON_PN}-nocasedict \
+ ${PYTHON_PN}-yamlloader \
+ ${PYTHON_PN}-click-repl \
+ ${PYTHON_PN}-click-spinner \
+ ${PYTHON_PN}-asciitree \
+ ${PYTHON_PN}-tabulate \
+ ${PYTHON_PN}-pydicti \
+ ${PYTHON_PN}-nocaselist \
+ ${PYTHON_PN}-custom-inherit \
+"
+
+BBCLASSEXTEND = "native"