summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python/recipes-extended')
-rw-r--r--meta-openembedded/meta-python/recipes-extended/python-cson/python3-cson_git.bb (renamed from meta-openembedded/meta-python/recipes-extended/python-cson/python-cson_git.bb)2
-rw-r--r--meta-openembedded/meta-python/recipes-extended/python-pyephem/python3-pyephem_3.7.7.0.bb (renamed from meta-openembedded/meta-python/recipes-extended/python-pyephem/python-pyephem_3.7.7.0.bb)2
-rw-r--r--meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.3.bb8
-rw-r--r--meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem_0.15.0.bb20
4 files changed, 2 insertions, 30 deletions
diff --git a/meta-openembedded/meta-python/recipes-extended/python-cson/python-cson_git.bb b/meta-openembedded/meta-python/recipes-extended/python-cson/python3-cson_git.bb
index efb338cf2..5c74c7a30 100644
--- a/meta-openembedded/meta-python/recipes-extended/python-cson/python-cson_git.bb
+++ b/meta-openembedded/meta-python/recipes-extended/python-cson/python3-cson_git.bb
@@ -15,7 +15,7 @@ S = "${WORKDIR}/git"
RDEPENDS_${PN}_class-native = ""
DEPENDS_append_class-native = " python-native "
-inherit setuptools
+inherit setuptools3
BBCLASSEXTEND = "native"
diff --git a/meta-openembedded/meta-python/recipes-extended/python-pyephem/python-pyephem_3.7.7.0.bb b/meta-openembedded/meta-python/recipes-extended/python-pyephem/python3-pyephem_3.7.7.0.bb
index 422f0dbc4..38b3c0a4f 100644
--- a/meta-openembedded/meta-python/recipes-extended/python-pyephem/python-pyephem_3.7.7.0.bb
+++ b/meta-openembedded/meta-python/recipes-extended/python-pyephem/python3-pyephem_3.7.7.0.bb
@@ -9,7 +9,7 @@ SRC_URI[sha256sum] = "607148429f85412915e32265779c0cf6d09f73aa97cf1ff0d101ac22c6
PYPI_PACKAGE = "ephem"
-inherit pypi setuptools
+inherit pypi setuptools3
RDEPENDS_${PN} += "\
${PYTHON_PN}-datetime \
diff --git a/meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.3.bb b/meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.3.bb
deleted file mode 100644
index 32aa378cc..000000000
--- a/meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.3.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-require python-pyparted.inc
-
-inherit distutils
-
-RDEPENDS_${PN} += "python-stringold python-codecs python-math python-subprocess"
-RDEPENDS_${PN}_class-native = ""
-
-BBCLASSEXTEND = "native"
diff --git a/meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem_0.15.0.bb b/meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem_0.15.0.bb
deleted file mode 100644
index a699f1c7e..000000000
--- a/meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem_0.15.0.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-require python-pywbem.inc
-inherit setuptools update-alternatives
-
-DEPENDS += " \
- ${PYTHON_PN}-m2crypto-native \
- ${PYTHON_PN}-typing-native \
-"
-
-RDEPENDS_${PN}_class-target += "\
- ${PYTHON_PN}-argparse \
- ${PYTHON_PN}-m2crypto \
- ${PYTHON_PN}-subprocess \
-"
-
-ALTERNATIVE_${PN} = "mof_compiler pywbemcli wbemcli"
-ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler"
-ALTERNATIVE_TARGET[pywbemcli] = "${bindir}/pywbemcli"
-ALTERNATIVE_TARGET[wbemcli] = "${bindir}/wbemcli"
-
-ALTERNATIVE_PRIORITY = "30"