summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-cmd2.inc13
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-cmd2_0.9.16.bb15
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-dbus_1.2.10.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python-dbus_1.2.8.bb)6
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-hyperlink.inc2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-paste_3.2.0.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python-paste_3.1.1.bb)4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pbr_5.4.3.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python-pbr_5.4.2.bb)4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pyasn1.inc4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pyasn1_0.4.7.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python-pyasn1_0.4.6.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pytest-asyncio.inc13
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pytest.inc4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pytest_5.1.2.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python-pytest_5.1.1.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-stevedore.inc4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-stevedore_1.31.0.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python-stevedore_1.30.1.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-twine.inc11
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_0.9.16.bb10
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-jinja2_2.10.1.bb2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pyasn1_0.4.7.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-pyasn1_0.4.6.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pyatspi_2.32.1.bb4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pytest_5.1.2.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-pytest_5.1.1.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-stevedore_1.31.0.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-stevedore_1.30.1.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-twine_1.13.0.bb2
22 files changed, 73 insertions, 27 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-cmd2.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-cmd2.inc
new file mode 100644
index 000000000..1a0be778b
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-cmd2.inc
@@ -0,0 +1,13 @@
+SUMMARY = "Extra features for standard library's cmd module"
+HOMEPAGE = "http://packages.python.org/cmd2/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=01aeabea7ae1529a8e4b674b7107d6bc"
+
+SRC_URI[md5sum] = "df35bb2dca8f5e1f6090e1f0aa02960a"
+SRC_URI[sha256sum] = "4b78379d53aff811d1deac720bbe71661769822a5fb2d830cd730656d180fb3d"
+
+inherit pypi
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-cmd2_0.9.16.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-cmd2_0.9.16.bb
index 94db37a2d..17b6ae285 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-cmd2_0.9.16.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-cmd2_0.9.16.bb
@@ -1,14 +1,5 @@
-SUMMARY = "Extra features for standard library's cmd module"
-HOMEPAGE = "http://packages.python.org/cmd2/"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=01aeabea7ae1529a8e4b674b7107d6bc"
-
-SRC_URI[md5sum] = "df35bb2dca8f5e1f6090e1f0aa02960a"
-SRC_URI[sha256sum] = "4b78379d53aff811d1deac720bbe71661769822a5fb2d830cd730656d180fb3d"
-
-inherit pypi setuptools
-
-DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+inherit setuptools
+require python-cmd2.inc
RDEPENDS_${PN} += "\
${PYTHON_PN}-doctest \
@@ -21,5 +12,3 @@ RDEPENDS_${PN} += "\
${PYTHON_PN}-threading \
${PYTHON_PN}-textutils \
"
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-dbus_1.2.8.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-dbus_1.2.10.bb
index b3f724054..9907ea953 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-dbus_1.2.8.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-dbus_1.2.10.bb
@@ -3,14 +3,14 @@ SECTION = "devel/python"
HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
LICENSE = "MIT & AFL-2.1 | GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b03240518994df6d8c974675675e5ca4 \
- file://dbus-gmain/COPYING;md5=05c3eacd50f69bb1d58afec460baad57 "
+ file://dbus-gmain/COPYING;md5=99fece6728a80737c8fd3e7c734c17c4 "
DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native"
SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
"
-SRC_URI[md5sum] = "7379db774c10904f27e7e2743d90fb43"
-SRC_URI[sha256sum] = "abf12bbb765e300bf8e2a1b2f32f85949eab06998dbda127952c31cb63957b6f"
+SRC_URI[md5sum] = "5d21d5ae6423f0e41caa3400af44edac"
+SRC_URI[sha256sum] = "d4332bbd4a0054fa4010b259c293b84d461bbd9d7a8ef528157d151c0398d886"
S = "${WORKDIR}/dbus-python-${PV}"
inherit distutils-base autotools pkgconfig
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-hyperlink.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-hyperlink.inc
index 25398541c..653170ca6 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-hyperlink.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-hyperlink.inc
@@ -8,7 +8,7 @@ SRC_URI[md5sum] = "4772fb4d87c26a1ab22a6161424e3cba"
inherit pypi
-RDEPENDS_${PN} += "${PYTHON_PN}-stringold ${PYTHON_PN}-netclient"
+RDEPENDS_${PN} += "${PYTHON_PN}-stringold ${PYTHON_PN}-netclient ${PYTHON_PN}-idna"
PACKAGES =. "${PN}-test "
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-paste_3.1.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-paste_3.2.0.bb
index 90e7970a5..92a97d1e0 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-paste_3.1.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-paste_3.2.0.bb
@@ -5,8 +5,8 @@ RDEPENDS_${PN} = "python-six"
LIC_FILES_CHKSUM = "file://docs/license.txt;md5=1798f29d55080c60365e6283cb49779c"
-SRC_URI[md5sum] = "07132313bc62c7525402d31119161228"
-SRC_URI[sha256sum] = "baca402a089594db0cf1e9aae5c98bcf91588bbbaf848527257e246b960eb72f"
+SRC_URI[md5sum] = "9225991c1c37a81e0aaac2fb046f3602"
+SRC_URI[sha256sum] = "2153da2f1b09a69bce7633d7e3f9aaa802572e85f9ac1ed09ad93ef8599d31b6"
PYPI_PACKAGE = "Paste"
inherit pypi setuptools
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pbr_5.4.2.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-pbr_5.4.3.bb
index 1023b2031..b21722fda 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-pbr_5.4.2.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pbr_5.4.3.bb
@@ -2,8 +2,8 @@ inherit setuptools
# The inc file is in oe-core
require recipes-devtools/python/python-pbr.inc
-SRC_URI[md5sum] = "ea90e1118a0132da752d45e68d10b2b8"
-SRC_URI[sha256sum] = "9b321c204a88d8ab5082699469f52cc94c5da45c51f114113d01b3d993c24cdf"
+SRC_URI[md5sum] = "477d2aa285ad97250a172b199f4060b7"
+SRC_URI[sha256sum] = "2c8e420cd4ed4cec4e7999ee47409e876af575d4c35a45840d59e8b5f3155ab8"
do_install_append() {
if [ -f ${D}${bindir}/pbr ]; then
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pyasn1.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-pyasn1.inc
index 1086f30bf..014fcf9a3 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-pyasn1.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pyasn1.inc
@@ -3,8 +3,8 @@ HOMEPAGE = "http://pyasn1.sourceforge.net/"
LICENSE = "BSD-2-Clause"
LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=a14482d15c2249de3b6f0e8a47e021fd"
-SRC_URI[md5sum] = "67f1da0cf680761d29169e54e7d53159"
-SRC_URI[sha256sum] = "b773d5c9196ffbc3a1e13bdf909d446cad80a039aa3340bcad72f395b76ebc86"
+SRC_URI[md5sum] = "50290e833395016c49903f4f9c7e47e5"
+SRC_URI[sha256sum] = "a9495356ca1d66ed197a0f72b41eb1823cf7ea8b5bd07191673e8147aecf8604"
RDEPENDS_${PN}_class-target += " \
${PYTHON_PN}-codecs \
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pyasn1_0.4.6.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-pyasn1_0.4.7.bb
index a13c74dda..a13c74dda 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-pyasn1_0.4.6.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pyasn1_0.4.7.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pytest-asyncio.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-pytest-asyncio.inc
new file mode 100644
index 000000000..9132c7452
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pytest-asyncio.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "pytest-asyncio is an Apache2 licensed library, written in Python, for testing asyncio code with pytest"
+HOMEPAGE = "https://github.com/pytest-dev/pytest-asyncio"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://README.rst;md5=ae62268d207c73b615fbefddaf91a881"
+
+SRC_URI[md5sum] = "247a7ec32f24a185341327c42a0f85bf"
+SRC_URI[sha256sum] = "9fac5100fd716cbecf6ef89233e8590a4ad61d729d1732e0a96b84182df1daaf"
+
+inherit pypi
+
+DEPENDS += "${PYTHON_PN}-pytest-native"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pytest.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-pytest.inc
index 49ef790f0..b58cdea96 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-pytest.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pytest.inc
@@ -3,8 +3,8 @@ HOMEPAGE = "http://pytest.org"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=640061b8cee64b308a4d2f9f556c12f2"
-SRC_URI[md5sum] = "662313b4f539f5b66d2fb77791458e82"
-SRC_URI[sha256sum] = "c3d5020755f70c82eceda3feaf556af9a341334414a8eca521a18f463bcead88"
+SRC_URI[md5sum] = "90fec5504fcebc5d1081bcd654df7cf0"
+SRC_URI[sha256sum] = "b78fe2881323bd44fd9bd76e5317173d4316577e7b1cddebae9136a4495ec865"
SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch \
"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pytest_5.1.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-pytest_5.1.2.bb
index 39e50aca9..39e50aca9 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-pytest_5.1.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pytest_5.1.2.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-stevedore.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-stevedore.inc
index 0aa0ef2fa..5aa9fb424 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-stevedore.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-stevedore.inc
@@ -3,8 +3,8 @@ HOMEPAGE = "https://github.com/dreamhost/stevedore"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
-SRC_URI[md5sum] = "02c747c39f4634465aa2590ceefddf59"
-SRC_URI[sha256sum] = "7be098ff53d87f23d798a7ce7ae5c31f094f3deb92ba18059b1aeb1ca9fec0a0"
+SRC_URI[md5sum] = "42fa2bf0251c96b543765c5ce13f37c9"
+SRC_URI[sha256sum] = "e0739f9739a681c7a1fda76a102b65295e96a144ccdb552f2ae03c5f0abe8a14"
inherit pypi
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-stevedore_1.30.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-stevedore_1.31.0.bb
index 70a00c131..70a00c131 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-stevedore_1.30.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-stevedore_1.31.0.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-twine.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-twine.inc
new file mode 100644
index 000000000..2bc778da2
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-twine.inc
@@ -0,0 +1,11 @@
+DESCRIPTION = "Six is a Python 2 and 3 compatibility library"
+HOMEPAGE = "https://github.com/benjaminp/six"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://README.rst;md5=3963bdcee7562bedae1effa09e7542b2"
+
+SRC_URI[md5sum] = "6fb4da0c7d81ddfd48f619b8caa1493c"
+SRC_URI[sha256sum] = "d6c29c933ecfc74e9b1d9fa13aa1f87c5d5770e119f5a4ce032092f0ff5b14dc"
+
+inherit pypi
+
+BBCLASSEXTEND = "native"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_0.9.16.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_0.9.16.bb
new file mode 100644
index 000000000..594e93dca
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_0.9.16.bb
@@ -0,0 +1,10 @@
+inherit setuptools3
+require python-cmd2.inc
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-pyperclip \
+ ${PYTHON_PN}-colorama \
+ ${PYTHON_PN}-attrs \
+ ${PYTHON_PN}-wcwidth \
+ "
+PNBLACKLIST[python3-cmd2] = "Nothing RPROVIDES 'python3-colorama' (but python3-cmd2_0.9.16.bb RDEPENDS on or otherwise requires it)"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-jinja2_2.10.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-jinja2_2.10.1.bb
index 61156b630..284f5f588 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-jinja2_2.10.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-jinja2_2.10.1.bb
@@ -1,2 +1,4 @@
inherit pypi setuptools3
require python-jinja2.inc
+
+RDEPENDS_${PN} += "${PYTHON_PN}-asyncio"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pyasn1_0.4.6.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyasn1_0.4.7.bb
index a5e2a7136..a5e2a7136 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pyasn1_0.4.6.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyasn1_0.4.7.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pyatspi_2.32.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyatspi_2.32.1.bb
index 6d80c1091..c60d40e3a 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pyatspi_2.32.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyatspi_2.32.1.bb
@@ -11,6 +11,10 @@ SRC_URI = "git://github.com/GNOME/pyatspi2.git;protocol=https;branch=gnome-3-32"
SRCREV = "dc4565208fca00da06b972915a080ad3c63f640d"
S = "${WORKDIR}/git"
+# Same restriction as gtk+
+inherit distro_features_check
+ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
+
inherit pkgconfig autotools python3native
FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/pyatspi/*"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb
new file mode 100644
index 000000000..09f26f8d1
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-pytest-asyncio.inc
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pytest_5.1.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pytest_5.1.2.bb
index eba6632a2..eba6632a2 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pytest_5.1.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pytest_5.1.2.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-stevedore_1.30.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-stevedore_1.31.0.bb
index 3f557f2cb..3f557f2cb 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-stevedore_1.30.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-stevedore_1.31.0.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-twine_1.13.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-twine_1.13.0.bb
new file mode 100644
index 000000000..0456ec92d
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-twine_1.13.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-twine.inc