summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-python')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-multidict_3.3.2.bb4
-rw-r--r--meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.1.bb2
-rw-r--r--meta-openembedded/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.1.bb2
3 files changed, 4 insertions, 4 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-multidict_3.3.2.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-multidict_3.3.2.bb
index 7f9cd5564..e65d7d4f2 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-multidict_3.3.2.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-multidict_3.3.2.bb
@@ -7,3 +7,7 @@ inherit pypi setuptools3
SRC_URI[md5sum] = "06ca91d993de2d04c7ee6df0cbb44ea2"
SRC_URI[sha256sum] = "f82e61c7408ed0dce1862100db55595481911f159d6ddec0b375d35b6449509b"
+
+# Work-around for broken make clean. Note this is fixed in v4.0.0.
+# https://github.com/aio-libs/multidict/issues/194
+CLEANBROKEN = "1"
diff --git a/meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.1.bb b/meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.1.bb
index 7d00fd7d9..32aa378cc 100644
--- a/meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.1.bb
+++ b/meta-openembedded/meta-python/recipes-extended/python-pyparted/python-pyparted_3.11.1.bb
@@ -1,7 +1,5 @@
require python-pyparted.inc
-PV = "3.10.7+git${SRCPV}"
-
inherit distutils
RDEPENDS_${PN} += "python-stringold python-codecs python-math python-subprocess"
diff --git a/meta-openembedded/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.1.bb b/meta-openembedded/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.1.bb
index 4d6f97b59..d83901ff3 100644
--- a/meta-openembedded/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.1.bb
+++ b/meta-openembedded/meta-python/recipes-extended/python-pyparted/python3-pyparted_3.11.1.bb
@@ -1,7 +1,5 @@
require python-pyparted.inc
-PV = "3.10.7+git${SRCPV}"
-
inherit distutils3
RDEPENDS_${PN} += "python3-stringold python3-codecs python3-math"