summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-xfce/recipes-multimedia/parole/parole_1.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openembedded/meta-xfce/recipes-multimedia/parole/parole_1.0.2.bb')
-rw-r--r--meta-openembedded/meta-xfce/recipes-multimedia/parole/parole_1.0.2.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-openembedded/meta-xfce/recipes-multimedia/parole/parole_1.0.2.bb b/meta-openembedded/meta-xfce/recipes-multimedia/parole/parole_1.0.2.bb
new file mode 100644
index 000000000..a286a5adb
--- /dev/null
+++ b/meta-openembedded/meta-xfce/recipes-multimedia/parole/parole_1.0.2.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Parole is a modern simple media player based on the GStreamer framework"
+HOMEPAGE = "http://goodies.xfce.org/projects/applications/parole"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
+
+inherit xfce-app gtk-doc mime
+
+DEPENDS += " \
+ glib-2.0 \
+ dbus-glib \
+ gtk+3 \
+ \
+ xfce4-dev-tools-native \
+ libxfce4util \
+ libxfce4ui \
+ xfconf \
+ \
+ gstreamer1.0-plugins-base \
+ taglib \
+"
+
+SRC_URI[md5sum] = "cd22ab579470c5728db0aa6c0b9d4c7d"
+SRC_URI[sha256sum] = "bff0fc846d0d7b8f435ac5514976f1cd1d82b62dbf1b7d470e253a5b439407da"
+
+RDEPENDS_${PN} += "gstreamer1.0-plugins-good"
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+PACKAGECONFIG ??= "notify"
+PACKAGECONFIG[clutter] = "--enable-clutter, --disable-clutter, clutter"
+PACKAGECONFIG[notify] = "--enable-notify-plugin, --disable-notify-plugin, libnotify"
+
+FILES_${PN} += " \
+ ${datadir}/appdata \
+ ${libdir}/parole-0/*.so \
+"