summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb')
-rw-r--r--meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb21
1 files changed, 1 insertions, 20 deletions
diff --git a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
index 08b58ea7c..505e23255 100644
--- a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
+++ b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
@@ -11,6 +11,7 @@ inherit autotools \
phosphor-dbus-yaml
require ${BPN}.inc
+require ${BPN}-systemd-links.inc
DEPENDS += " \
phosphor-logging \
@@ -26,26 +27,6 @@ APPS = "checkstop watchdog"
DEBUG_TMPL = "openpower-debug-collector-{0}@.service"
SYSTEMD_SERVICE_${PN} += "${@compose_list(d, 'DEBUG_TMPL', 'APPS')}"
-# This needs to be executed as part of host crash
-CHECKSTOP_TMPL = "openpower-debug-collector-checkstop@.service"
-CRASH_TGTFMT = "obmc-host-crash@{0}.target"
-CHECKSTOP_INSTFMT = "openpower-debug-collector-checkstop@{0}.service"
-CRASH_CHECKSTOP_FMT = "../${CHECKSTOP_TMPL}:${CRASH_TGTFMT}.wants/${CHECKSTOP_INSTFMT}"
-
-# Make watchdog part of obmc-host-timeout target
-WDOG_TMPL = "openpower-debug-collector-watchdog@.service"
-TIMEOUT_TGTFMT = "obmc-host-timeout@{0}.target"
-WDOG_INSTFMT = "openpower-debug-collector-watchdog@{0}.service"
-TIMEOUT_WDOG_FMT = "../${WDOG_TMPL}:${TIMEOUT_TGTFMT}.wants/${WDOG_INSTFMT}"
-
-# Capture debug information on watchdog timeout
-DEBUG_WD_TIMEOUT_TMPL = "openpower-debug-collector-watchdog-timeout@.service"
-DEBUG_WD_TIMEOUT_INSTFMT = "openpower-debug-collector-watchdog-timeout@{0}.service"
-DEBUG_WD_TIMEOUT_FMT = "../${DEBUG_WD_TIMEOUT_TMPL}:${TIMEOUT_TGTFMT}.wants/${DEBUG_WD_TIMEOUT_INSTFMT}"
-
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'CRASH_CHECKSTOP_FMT', 'OBMC_HOST_INSTANCES')}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'TIMEOUT_WDOG_FMT', 'OBMC_HOST_INSTANCES')}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'DEBUG_WD_TIMEOUT_FMT', 'OBMC_HOST_INSTANCES')}"
# Do not depend on phosphor-logging for native build
DEPENDS_remove_class-native = "phosphor-logging"