summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/flash
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor/flash')
-rw-r--r--meta-openpower/recipes-phosphor/flash/host-fw_git.bb33
-rw-r--r--meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb18
2 files changed, 16 insertions, 35 deletions
diff --git a/meta-openpower/recipes-phosphor/flash/host-fw_git.bb b/meta-openpower/recipes-phosphor/flash/host-fw_git.bb
deleted file mode 100644
index 00fc1fd59..000000000
--- a/meta-openpower/recipes-phosphor/flash/host-fw_git.bb
+++ /dev/null
@@ -1,33 +0,0 @@
-SUMMARY = "OpenPOWER Host Firmware Image"
-DESCRIPTION = "Adds the OpenPOWER Host Firmware image to the BMC image"
-PR = "r1"
-
-inherit allarch
-
-HOST_FW_LICENSE ?= "Apache-2.0"
-HOST_FW_LIC_FILES_CHKSUM ?= "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-HOST_FW_SRC_URI ?= ""
-
-LICENSE = "${HOST_FW_LICENSE}"
-LIC_FILES_CHKSUM = "${HOST_FW_LIC_FILES_CHKSUM}"
-SRC_URI = "${HOST_FW_SRC_URI}"
-
-DEPENDS = "squashfs-tools-native"
-
-S = "${WORKDIR}"
-B = "${WORKDIR}/build"
-do_compile[cleandirs] = "${B}"
-
-do_compile() {
- if [ -n "${HOST_FW_SRC_URI}" ]; then
- unsquashfs -d ${B}/squashfs-root ${S}/pnor.xz.squashfs
- fi
-}
-
-do_install() {
- install -d ${D}${datadir}/${BPN}
-
- if [ -n "${HOST_FW_SRC_URI}" ]; then
- install -m 0440 ${B}/squashfs-root/* ${D}${datadir}/${BPN}
- fi
-}
diff --git a/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb b/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
index 930ad0ea3..1116f34f4 100644
--- a/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
+++ b/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
@@ -11,15 +11,29 @@ LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
inherit autotools pkgconfig systemd
inherit obmc-phosphor-dbus-service
+# Static configuration. This is the default if no other layout is specified.
+inherit ${@bb.utils.contains_any('DISTRO_FEATURES', \
+ 'openpower-ubi-fs phosphor-mmc', \
+ '', \
+ 'openpower-software-manager-static', d)}
+
+# UBI layout
inherit ${@bb.utils.contains('DISTRO_FEATURES', 'openpower-ubi-fs', \
'openpower-software-manager-ubi', \
- 'openpower-software-manager-static', d)}
+ '', d)}
+# eMMC layout
+inherit ${@bb.utils.contains('DISTRO_FEATURES', 'phosphor-mmc', \
+ 'openpower-software-manager-mmc', \
+ '', d)}
+
+# Virtual PNOR
inherit ${@bb.utils.contains('DISTRO_FEATURES', 'openpower-virtual-pnor', \
'openpower-software-manager-virtual-pnor', \
'', d)}
PACKAGECONFIG[verify_pnor_signature] = "--enable-verify_pnor_signature,--disable-verify_pnor_signature"
PACKAGECONFIG[ubifs_layout] = "--enable-ubifs_layout,--disable-ubifs_layout,,mtd-utils-ubifs"
+PACKAGECONFIG[mmc_layout] = "--enable-mmc_layout,--disable-mmc_layout"
PACKAGECONFIG[virtual_pnor] = "--enable-virtual_pnor,--disable-virtual_pnor"
EXTRA_OECONF += " \
@@ -42,7 +56,7 @@ S = "${WORKDIR}/git"
SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt"
-SRCREV = "4c955c31d96d4e3781abd9e9f9cf5c6aa1adfd56"
+SRCREV = "7c053c3f496c73b73e7677713f3e22fb1d3e56ab"
DBUS_SERVICE_${PN} += "org.open_power.Software.Host.Updater.service"